summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHank Leininger <hlein@korelogic.com>2020-06-07 18:56:17 -0600
committerJoonas Niilola <juippis@gentoo.org>2020-06-08 16:41:24 +0300
commited0e9b7be2c1dc78c6c8b3ec61d0bff209096a31 (patch)
tree6dd0b1f6ce84be4a373259f7ed45955e437e5cbe /app-crypt
parentapp-crypt/aespipe: Added myself as proxy maintainer. (diff)
downloadgentoo-ed0e9b7be2c1dc78c6c8b3ec61d0bff209096a31.tar.gz
gentoo-ed0e9b7be2c1dc78c6c8b3ec61d0bff209096a31.tar.bz2
gentoo-ed0e9b7be2c1dc78c6c8b3ec61d0bff209096a31.zip
app-crypt/aespipe: Version bump to 2.4f
Signed-off-by: Hank Leininger <hlein@korelogic.com> Closes: https://bugs.gentoo.org/702738 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/aespipe/Manifest1
-rw-r--r--app-crypt/aespipe/aespipe-2.4f.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/app-crypt/aespipe/Manifest b/app-crypt/aespipe/Manifest
index bbd777bf6d57..1be556a24c27 100644
--- a/app-crypt/aespipe/Manifest
+++ b/app-crypt/aespipe/Manifest
@@ -1 +1,2 @@
DIST aespipe-v2.4e.tar.bz2 107741 BLAKE2B 9331441214b495f042f8ac41b57203057e762156aa7b6bd9fcb8d55b3e149fb79dd0d7c06358599fefd6662d797baf4cf9ba84fc4425e637c9fef0abf1b254c7 SHA512 e038f710ac971e5ba740648c0f255e8bc9fcea9be1a6b76208a453f21f013e1662c006d4f4495fa2b2560fd9b0c236947462a9b337a120073c6a5335b29f077e
+DIST aespipe-v2.4f.tar.bz2 107663 BLAKE2B 80af945ec938307ddaeb1a1f7a91da71d4f1aeabe4cb303166cad95c36e0d0090fd8440bb636ac0245d2701d61fdea715c84e18dfacf32bfba7f4b85a2db091f SHA512 75b6b2069a0e013dbded29b07b990fc783cc04ce05fc37e6591dae7e8190485960735ec1a1af18d065be57d0b7ec23dbe520e920f92e9c01170b7a23eb32eb3f
diff --git a/app-crypt/aespipe/aespipe-2.4f.ebuild b/app-crypt/aespipe/aespipe-2.4f.ebuild
new file mode 100644
index 000000000000..3ead8cc5fb4e
--- /dev/null
+++ b/app-crypt/aespipe/aespipe-2.4f.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="Encrypts data from stdin to stdout"
+HOMEPAGE="http://loop-aes.sourceforge.net"
+SRC_URI="http://loop-aes.sourceforge.net/aespipe/${PN}-v${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+IUSE="+asm cpu_flags_x86_aes cpu_flags_x86_padlock static"
+RDEPEND="app-arch/sharutils
+ app-crypt/gnupg"
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_configure() {
+ use static && append-ldflags -static
+ econf \
+ $(use_enable asm) \
+ $(use_enable cpu_flags_x86_aes intelaes) \
+ $(use_enable cpu_flags_x86_padlock padlock)
+}