summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-02-02 17:44:19 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-02-02 17:44:19 +0100
commitf635ca61de46a7f21a397871c05ba3c69872f0c3 (patch)
treee6bb588f99b996c59937f02a03b85fb2af4aecfb /app-crypt
parentdev-util/jenkins-bin: Remove old (diff)
downloadgentoo-f635ca61de46a7f21a397871c05ba3c69872f0c3.tar.gz
gentoo-f635ca61de46a7f21a397871c05ba3c69872f0c3.tar.bz2
gentoo-f635ca61de46a7f21a397871c05ba3c69872f0c3.zip
app-crypt/acme: Version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/acme/Manifest1
-rw-r--r--app-crypt/acme/acme-0.3.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-crypt/acme/Manifest b/app-crypt/acme/Manifest
index d48ba771d618..66cfd27c90b9 100644
--- a/app-crypt/acme/Manifest
+++ b/app-crypt/acme/Manifest
@@ -1 +1,2 @@
DIST letsencrypt-0.2.0.tar.gz 564016 SHA256 71324323eb6c9fe9a2cee95f012a44e9c7bdc8c9dfe14c26d56129306f188650 SHA512 a00618c0f3ae78cfdb70adfea81ff9d672123fa38585cfda8ed44659be14bd37143f2c5bc076b92d116356437ea08af079142a4ae09a8a6ad06f2793276b973e WHIRLPOOL cd413fd1ca4d2e462bcc573c8b0403010cfc27dca577c56c1465e5d794e7769a0621bac361078762eec12f2296d968421572cb8794cb1a49824b37292dbab572
+DIST letsencrypt-0.3.0.tar.gz 627761 SHA256 a21e496ab130cf9fcaeef69019a4eef7aaf86dad84131d601db531add4f98e1a SHA512 c3fbb6d8a50ee9a84b425d16f28626cecb3b50a5149c1263d02d447854d9117c6fe4f3f2eef7f026c9d7692a499a054895a2b007da9f768c203ea91836382f36 WHIRLPOOL fa87cb033c4a45737abeb706312ac9c4fa2ab921c07cc05f1feaeb4f083727f4ba1a819035345e5dfead536d762025ef8a4eeaa6d039b64efa3350f2a64e64a5
diff --git a/app-crypt/acme/acme-0.3.0.ebuild b/app-crypt/acme/acme-0.3.0.ebuild
new file mode 100644
index 000000000000..703410c10135
--- /dev/null
+++ b/app-crypt/acme/acme-0.3.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python{2_7,3_4,3_5})
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/letsencrypt/letsencrypt.git"
+ inherit git-r3
+ KEYWORDS=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/letsencrypt/letsencrypt/archive/v${PV}.tar.gz -> letsencrypt-${PV}.tar.gz"
+ KEYWORDS="~amd64"
+ S=${WORKDIR}/letsencrypt-${PV}/acme
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="An implementation of the ACME protocol"
+HOMEPAGE="https://github.com/letsencrypt/letsencrypt https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=">=dev-python/cryptography-0.8[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/ndg-httpsclient-0.4[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.15[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND} dev-python/nose[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ nosetests -w ${PN} || die
+}