summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2018-05-18 19:15:49 -0400
committerGöktürk Yüksek <gokturk@gentoo.org>2018-05-18 19:19:29 -0400
commitf65929c26f1210b1d0987ce8d55800d8e9dfdc87 (patch)
tree837f37e8352ad7188057e10aa133e0ee2fc1d12c /app-crypt
parentdev-python/fido2: initial commit with version 0.3.0 (diff)
downloadgentoo-f65929c26f1210b1d0987ce8d55800d8e9dfdc87.tar.gz
gentoo-f65929c26f1210b1d0987ce8d55800d8e9dfdc87.tar.bz2
gentoo-f65929c26f1210b1d0987ce8d55800d8e9dfdc87.zip
app-crypt/yubikey-manager: bump to 0.7.0
Regarding the test fix patch, see: https://github.com/Yubico/yubikey-manager/issues/111 Package-Manager: Portage-2.3.27, Repoman-2.3.9
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/yubikey-manager/Manifest1
-rw-r--r--app-crypt/yubikey-manager/files/yubikey-manager-0.7.0-fix-tests.patch24
-rw-r--r--app-crypt/yubikey-manager/yubikey-manager-0.7.0.ebuild62
3 files changed, 87 insertions, 0 deletions
diff --git a/app-crypt/yubikey-manager/Manifest b/app-crypt/yubikey-manager/Manifest
index 165cacd2dd84..2a0e3eea2a06 100644
--- a/app-crypt/yubikey-manager/Manifest
+++ b/app-crypt/yubikey-manager/Manifest
@@ -3,3 +3,4 @@ DIST yubikey-manager-0.4.5.tar.gz 55315 BLAKE2B 231706a14ba9d65474c8bd92cc57fec3
DIST yubikey-manager-0.4.6.tar.gz 55065 BLAKE2B a0e8d85252836a6d99e68f637f42397266187372b0fd0723ea6d330a01e42a2b79d9fc5f283d7fab2378fe847aaf0cb307f16694ce59f41aabd7fcc668be01fe SHA512 fd52cb346e95b3184fd8e4bbb8e227c75780d7fcf5057712c6def866ea951700f8cdd1286ff857e32754d539dfc7093d809fc585191b05c57f5f983d5b288e7e
DIST yubikey-manager-0.5.0.tar.gz 59672 BLAKE2B e5dbd32ba644e7b20f03c1511a4ff608c0e6dc93c115edd50077a9a41699411a5fd0eff3d62af1fb13545d977037510f696cbd27150e21308624bfc8613f8bcb SHA512 3a503ced29a557c5adafdd1bc6025a405962cabab7388c96e8f5582165bd33111adeb3b77c7c928cbac905fb085d53ddaefbb12169b54e62b7337c1989636a8a
DIST yubikey-manager-0.6.0.tar.gz 77823 BLAKE2B 37d9a7e72135ba859521f209896c47423f3573b2f14a56956d145334124f7bf5a4259401a9e89e3f19b2e01a476b96a984e801a28a256815a7773baa44e71773 SHA512 fb49887f4646fe63874be9cb3510ef0d1f9b931ac5fb78f3cc82fb93ada94b36aa06fd91e2ee9d4ea868abedfc206dbedd02fa0c4385d5557d33e07e8099e761
+DIST yubikey-manager-0.7.0.tar.gz 83385 BLAKE2B cd0c440f8ce81549e52dd8e546d82678c19d95d2257c878b48d69719031317943bcca4ee713c03ca8f3fa1de4363df629b09b005955a1217adb2dc5ce89400aa SHA512 0fec23dafd2502a1508648fc96f1dcc873eaf3ad089f87b1afd94b35391513ad3a799985fcbc201c2fb4a3a3e473d24483c04a6862117d211c4cb6b294f74be0
diff --git a/app-crypt/yubikey-manager/files/yubikey-manager-0.7.0-fix-tests.patch b/app-crypt/yubikey-manager/files/yubikey-manager-0.7.0-fix-tests.patch
new file mode 100644
index 000000000000..46074d2241a5
--- /dev/null
+++ b/app-crypt/yubikey-manager/files/yubikey-manager-0.7.0-fix-tests.patch
@@ -0,0 +1,24 @@
+diff --git b/test/util.py a/test/util.py
+new file mode 100644
+index 0000000..0551d06
+--- /dev/null
++++ a/test/util.py
+@@ -0,0 +1,18 @@
++from click.testing import CliRunner
++from ykman.cli.__main__ import cli
++import os
++
++
++PKG_DIR = os.path.dirname(os.path.abspath(__file__))
++
++
++def open_file(*relative_path):
++ return open(os.path.join(PKG_DIR, 'files', *relative_path), 'rb')
++
++
++def ykman_cli(*argv, **kwargs):
++ runner = CliRunner()
++ result = runner.invoke(cli, list(argv), obj={}, **kwargs)
++ if result.exit_code != 0:
++ raise result.exception
++ return result.output
diff --git a/app-crypt/yubikey-manager/yubikey-manager-0.7.0.ebuild b/app-crypt/yubikey-manager/yubikey-manager-0.7.0.ebuild
new file mode 100644
index 000000000000..7b8bda82e71a
--- /dev/null
+++ b/app-crypt/yubikey-manager/yubikey-manager-0.7.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+inherit readme.gentoo-r1 distutils-r1
+
+DESCRIPTION="Python library and command line tool for configuring a YubiKey"
+HOMEPAGE="https://developers.yubico.com/yubikey-manager/"
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-python/fido2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/pyscard[${PYTHON_USEDEP}]
+ dev-python/pyusb[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7)
+ sys-auth/ykpers
+"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' 'python2_7')
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.7.0-fix-tests.patch
+)
+
+python_test() {
+ touch "${S}"/test/__init__.py || die
+ esetup.py test
+}
+
+python_install_all() {
+ local DOC_CONTENTS
+
+ distutils-r1_python_install_all
+
+ DOC_CONTENTS="
+ The 'openpgp' command may require the package 'app-crypt/ccid'
+ to be installed on the system. Furthermore, make sure that pcscd
+ daemon is running and has correct access permissions to USB
+ devices.
+ "
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}