summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Haubenwallner <haubi@gentoo.org>2017-03-16 12:17:17 +0100
committerRobin H. Johnson <robbat2@gentoo.org>2017-03-17 20:12:23 -0700
commitfcaa447949816ba0dcedb15a0af8860dc3cb9972 (patch)
tree962db4feda706e246806c358ac56457ffa9c3958 /app-crypt
parentx11-libs/qtermwidget: remove old (diff)
downloadgentoo-fcaa447949816ba0dcedb15a0af8860dc3cb9972.tar.gz
gentoo-fcaa447949816ba0dcedb15a0af8860dc3cb9972.tar.bz2
gentoo-fcaa447949816ba0dcedb15a0af8860dc3cb9972.zip
app-crypt/gnupg: apply upstream patch around strlwr
Package-Manager: portage-2.3.3 (cherry picked from commit 628d928a0a249334c9887291a595b4fbe96b1014) Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/gnupg/files/gnupg-2.1.19-have_strlwr.patch56
-rw-r--r--app-crypt/gnupg/gnupg-2.1.19-r1.ebuild1
2 files changed, 57 insertions, 0 deletions
diff --git a/app-crypt/gnupg/files/gnupg-2.1.19-have_strlwr.patch b/app-crypt/gnupg/files/gnupg-2.1.19-have_strlwr.patch
new file mode 100644
index 000000000000..eae8d9ea3f9a
--- /dev/null
+++ b/app-crypt/gnupg/files/gnupg-2.1.19-have_strlwr.patch
@@ -0,0 +1,56 @@
+https://lists.gnupg.org/pipermail/gnupg-devel/2017-March/032668.html
+
+From c22a2a89d3bd3d08b3abb8e4e33df32b480338ec Mon Sep 17 00:00:00 2001
+From: Michael Haubenwallner <michael.haubenwallner@ssi-schaefer.com>
+Date: Tue, 7 Mar 2017 13:54:49 +0100
+Subject: [PATCH] gpgscm: Use system strlwr if available.
+
+* tests/gpgscm/scheme.c: Define local strlwr only when HAVE_STRLWR is
+not defined in config.h.
+* tests/gpgscm/scheme-config.h: Remove hack.
+
+Signed-off-by: Justus Winter <justus@g10code.com>
+---
+ tests/gpgscm/scheme-config.h | 4 ----
+ tests/gpgscm/scheme.c | 6 +++++-
+ 2 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/tests/gpgscm/scheme-config.h b/tests/gpgscm/scheme-config.h
+index 2003498..15ca969 100644
+--- a/tests/gpgscm/scheme-config.h
++++ b/tests/gpgscm/scheme-config.h
+@@ -30,7 +30,3 @@
+ #define USE_PLIST 0
+ #define USE_INTERFACE 1
+ #define SHOW_ERROR_LINE 1
+-
+-#if __MINGW32__
+-# define USE_STRLWR 0
+-#endif /* __MINGW32__ */
+diff --git a/tests/gpgscm/scheme.c b/tests/gpgscm/scheme.c
+index b2ff721..af97c27 100644
+--- a/tests/gpgscm/scheme.c
++++ b/tests/gpgscm/scheme.c
+@@ -12,6 +12,10 @@
+ *
+ */
+
++#ifdef HAVE_CONFIG_H
++# include <config.h>
++#endif
++
+ #define _SCHEME_SOURCE
+ #include "scheme-private.h"
+ #ifndef WIN32
+@@ -88,7 +92,7 @@ static int stricmp(const char *s1, const char *s2)
+ }
+ #endif /* __APPLE__ */
+
+-#if USE_STRLWR
++#if USE_STRLWR && !defined(HAVE_STRLWR)
+ static const char *strlwr(char *s) {
+ const char *p=s;
+ while(*s) {
+--
+2.10.2
+
diff --git a/app-crypt/gnupg/gnupg-2.1.19-r1.ebuild b/app-crypt/gnupg/gnupg-2.1.19-r1.ebuild
index 61ca2088adef..a9bfccac46fa 100644
--- a/app-crypt/gnupg/gnupg-2.1.19-r1.ebuild
+++ b/app-crypt/gnupg/gnupg-2.1.19-r1.ebuild
@@ -56,6 +56,7 @@ PATCHES=(
"${FILESDIR}/${PN}-2.1.16-gpgscm-Use-shorter-socket-path-lengts-to-improve-tes.patch"
"${FILESDIR}"/${P}-solaris-ucred.patch
"${FILESDIR}"/${P}-ssh-no-scdaemon.patch
+ "${FILESDIR}"/${P}-have_strlwr.patch
)
src_configure() {