summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2017-04-08 18:03:46 +0200
committerSebastian Pipping <sping@gentoo.org>2017-04-08 18:04:25 +0200
commitff059ce089f72d0cc53f0335a54babc9004a3e47 (patch)
tree58346dce77872592cfe07ee9a7eb7289589c4164 /app-crypt
parentkde-frameworks: Add KDE Frameworks 5.33.0 release (diff)
downloadgentoo-ff059ce089f72d0cc53f0335a54babc9004a3e47.tar.gz
gentoo-ff059ce089f72d0cc53f0335a54babc9004a3e47.tar.bz2
gentoo-ff059ce089f72d0cc53f0335a54babc9004a3e47.zip
app-crypt/debian-archive-keyring: Fix compilation (bug #614932)
Thanks to Toralf Foerster Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/debian-archive-keyring/debian-archive-keyring-2014.3.ebuild8
-rw-r--r--app-crypt/debian-archive-keyring/files/debian-archive-keyring-2014.3-order.patch36
2 files changed, 42 insertions, 2 deletions
diff --git a/app-crypt/debian-archive-keyring/debian-archive-keyring-2014.3.ebuild b/app-crypt/debian-archive-keyring/debian-archive-keyring-2014.3.ebuild
index b0acabf6bc8a..fde180a215f9 100644
--- a/app-crypt/debian-archive-keyring/debian-archive-keyring-2014.3.ebuild
+++ b/app-crypt/debian-archive-keyring/debian-archive-keyring-2014.3.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
DESCRIPTION="GnuPG archive keys of the Debian archive"
HOMEPAGE="http://packages.debian.org/sid/debian-archive-keyring"
@@ -15,3 +15,7 @@ IUSE=""
DEPEND="app-crypt/jetring"
MAKEOPTS+=' -j1'
+
+PATCHES=(
+ "${FILESDIR}"/${P}-order.patch
+)
diff --git a/app-crypt/debian-archive-keyring/files/debian-archive-keyring-2014.3-order.patch b/app-crypt/debian-archive-keyring/files/debian-archive-keyring-2014.3-order.patch
new file mode 100644
index 000000000000..59b2412bf99b
--- /dev/null
+++ b/app-crypt/debian-archive-keyring/files/debian-archive-keyring-2014.3-order.patch
@@ -0,0 +1,36 @@
+From fdf28f2cb17ae0bf8fac569335dabdbc9e83a452 Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Sat, 8 Apr 2017 14:55:06 +0200
+Subject: [PATCH] Ensure verification starts after build
+
+---
+ Makefile | 9 +++++++--
+ 1 file changed, 7 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 0952a5d..b722226 100644
+--- a/Makefile
++++ b/Makefile
+@@ -3,7 +3,12 @@ TMPRING := trusted.gpg/build-area
+
+ GPG_OPTIONS := --no-options --no-default-keyring --no-auto-check-trustdb --trustdb-name ./trustdb.gpg
+
+-build: verify-indices keyrings/debian-archive-keyring.gpg keyrings/debian-archive-removed-keys.gpg verify-results $(TRUSTED-LIST)
++all:
++ $(MAKE) build verify
++
++build: keyrings/debian-archive-keyring.gpg keyrings/debian-archive-removed-keys.gpg $(TRUSTED-LIST)
++
++verify: verify-indices verify-results
+
+ verify-indices: keyrings/team-members.gpg
+ gpg ${GPG_OPTIONS} \
+@@ -61,4 +66,4 @@ install: build
+ install -d $(DESTDIR)/etc/apt/trusted.gpg.d/
+ cp $(shell find trusted.gpg/ -name '*.gpg' -type f) $(DESTDIR)/etc/apt/trusted.gpg.d/
+
+-.PHONY: verify-indices verify-results clean build install
++.PHONY: all verify verify-indices verify-results clean build install
+--
+2.12.2
+