summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-12-16 23:12:15 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-12-16 23:26:46 +0100
commit9e0b93f4b74d59ba2ca16354a9a92ed3affabd1c (patch)
tree20a5bd6e7cc4f5dfde68652aa50445dab7768811 /app-dicts/aspell-be/aspell-be-0.01-r2.ebuild
parentapp-dicts/aspell-zu: drop 0.50.0 (diff)
downloadgentoo-9e0b93f4b74d59ba2ca16354a9a92ed3affabd1c.tar.gz
gentoo-9e0b93f4b74d59ba2ca16354a9a92ed3affabd1c.tar.bz2
gentoo-9e0b93f4b74d59ba2ca16354a9a92ed3affabd1c.zip
app-dicts/aspell-be: update EAPI 7 -> 8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-dicts/aspell-be/aspell-be-0.01-r2.ebuild')
-rw-r--r--app-dicts/aspell-be/aspell-be-0.01-r2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-dicts/aspell-be/aspell-be-0.01-r2.ebuild b/app-dicts/aspell-be/aspell-be-0.01-r2.ebuild
new file mode 100644
index 000000000000..b2ec769036cb
--- /dev/null
+++ b/app-dicts/aspell-be/aspell-be-0.01-r2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ASPELL_LANG="Belarusian"
+ASPELL_VERSION=5
+MY_P="${PN/aspell/aspell${ASPELL_VERSION}}-${PV}"
+
+inherit aspell-dict-r1
+
+SRC_URI="mirror://gnu/${PN%-*}/dict/${PN/aspell-/}/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+IUSE="classic"
+
+src_prepare() {
+ ! use classic && local PATCHES=( "${FILESDIR}"/aspell5-be-${PV}-official.patch )
+
+ default
+}