summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElizabeth Myers <elizabeth@interlinked.me>2016-03-04 02:46:39 -0600
committerElizabeth Myers <elizabeth@interlinked.me>2016-03-04 02:51:37 -0600
commit3bbd8bc569367fc7ccf0a7c3fd0aaf359ee71e16 (patch)
tree79378f0321359df4c683a218db276869f8a3ace5 /app-dicts/myspell-es/myspell-es-0.7.ebuild
parentdev-java/toolbar: EAPI 5 bump. (diff)
downloadgentoo-3bbd8bc569367fc7ccf0a7c3fd0aaf359ee71e16.tar.gz
gentoo-3bbd8bc569367fc7ccf0a7c3fd0aaf359ee71e16.tar.bz2
gentoo-3bbd8bc569367fc7ccf0a7c3fd0aaf359ee71e16.zip
app-dicts/myspell-es: update to 0.7
Diffstat (limited to 'app-dicts/myspell-es/myspell-es-0.7.ebuild')
-rw-r--r--app-dicts/myspell-es/myspell-es-0.7.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-dicts/myspell-es/myspell-es-0.7.ebuild b/app-dicts/myspell-es/myspell-es-0.7.ebuild
new file mode 100644
index 000000000000..ae3ca6650b1b
--- /dev/null
+++ b/app-dicts/myspell-es/myspell-es-0.7.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# yay for modern download tools like redmine and their unique IDs as part of
+# the URL - this means that someone needs to check the download page if there
+# are new releases:
+# http://forja.rediris.es/frs/?group_id=341
+# When checking ensure you update id above as well as the order of MUTATIONS if
+# necessary.
+MUTATIONS="es_ANY es_VE es_UY es_SV es_PY es_PR es_PE es_PA es_NI es_MX es_HN
+es_GT es_ES es_EC es_DO es_CU es_CR es_CO es_CL es_BO es_AR"
+d_id=2933
+
+MYSPELL_DICT=( )
+MYSPELL_HYPH=(
+ "hyph_es_ANY.dic"
+)
+MYSPELL_THES=(
+ "th_es_ES_v2.dat"
+ "th_es_ES_v2.idx"
+)
+
+SRC_URI=""
+for i in ${MUTATIONS}; do
+ MYSPELL_DICT+=(
+ "${i}.dic"
+ "${i}.aff"
+ )
+ SRC_URI+=" http://forja.rediris.es/frs/download.php/${d_id}/${i}.oxt -> ${i}-${PV}.oxt"
+ let d_id=${d_id}+1
+done
+unset i d_id
+
+inherit myspell-r2
+
+DESCRIPTION="Spanish dictionaries for myspell/hunspell"
+HOMEPAGE="http://rla-es.forja.rediris.es/"
+LICENSE="GPL-3 LGPL-3 MPL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+src_prepare() {
+ # remove license files
+ rm -rf {GPL,LGPL,MPL}*
+ default
+}