summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-dicts/myspell-hu/myspell-hu-1.6.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-dicts/myspell-hu/myspell-hu-1.6.1.ebuild')
-rw-r--r--app-dicts/myspell-hu/myspell-hu-1.6.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-dicts/myspell-hu/myspell-hu-1.6.1.ebuild b/app-dicts/myspell-hu/myspell-hu-1.6.1.ebuild
new file mode 100644
index 000000000000..f6c551f04b12
--- /dev/null
+++ b/app-dicts/myspell-hu/myspell-hu-1.6.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+MYSPELL_DICT=(
+ "hu_HU-${PV}/hu_HU.aff"
+ "hu_HU-${PV}/hu_HU.dic"
+)
+
+MYSPELL_HYPH=(
+ "huhyphn_v20110815_LibO/hyph_hu_HU.dic"
+)
+
+MYSPELL_THES=(
+ "opt/libreoffice3.6/share/extensions/dict-hu/th_hu_HU_v2.dat"
+ "opt/libreoffice3.6/share/extensions/dict-hu/th_hu_HU_v2.idx"
+)
+
+inherit rpm myspell-r2
+
+DESCRIPTION="Hungarian dictionaries for myspell/hunspell"
+HOMEPAGE="http://magyarispell.sourceforge.net/"
+SRC_URI="
+ mirror://sourceforge/magyarispell/hu_HU-${PV}.tar.gz
+ mirror://sourceforge/magyarispell/huhyphn_v20110815_LibO.tar.gz
+ http://downloadarchive.documentfoundation.org/libreoffice/old/3.6.0.4/rpm/x86/LibO_3.6.0.4_Linux_x86_langpack-rpm_hu.tar.gz
+"
+# Hyphen seems to have no releases but was not updated in last 4 years, just use
+# one arived version from libreoffice and be done with it. If it needs update
+# users can ope a bug.
+
+LICENSE="GPL-3 GPL-2 LGPL-2.1 MPL-1.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+src_unpack() {
+ myspell-r2_src_unpack
+
+ rpm_unpack ./LibO_3.6.0.4_Linux_x86_langpack-rpm_hu/RPMS/libreoffice3.6-dict-hu-3.6.0.4-104.i586.rpm
+}