summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Kurakin <kuraga333@mail.ru>2019-10-19 13:30:00 +0300
committerJoonas Niilola <juippis@gentoo.org>2019-11-06 09:07:39 +0200
commit883535534dcb71a71a1a7b3653bbd71f78704b5c (patch)
treeffb81c7d394cb6f2442c7f2287eb8e1721b02ec2 /app-dicts/myspell-ru/myspell-ru-20180627.ebuild
parentdev-libs/libffi: RESTRICT="!test? ( test )" (diff)
downloadgentoo-883535534dcb71a71a1a7b3653bbd71f78704b5c.tar.gz
gentoo-883535534dcb71a71a1a7b3653bbd71f78704b5c.tar.bz2
gentoo-883535534dcb71a71a1a7b3653bbd71f78704b5c.zip
app-dicts/myspell-ru: bump to 20180627
Signed-off-by: Alexander Kurakin <kuraga333@mail.ru> Closes: https://bugs.gentoo.org/667146 Based on https://github.com/gentoo/gentoo/pull/9982 Closes: https://github.com/gentoo/gentoo/pull/13344 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-dicts/myspell-ru/myspell-ru-20180627.ebuild')
-rw-r--r--app-dicts/myspell-ru/myspell-ru-20180627.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-dicts/myspell-ru/myspell-ru-20180627.ebuild b/app-dicts/myspell-ru/myspell-ru-20180627.ebuild
new file mode 100644
index 000000000000..e9a980203237
--- /dev/null
+++ b/app-dicts/myspell-ru/myspell-ru-20180627.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MYSPELL_DICT=( ru_RU.{dic,aff} )
+MYSPELL_HYPH=( hyph_ru_RU.dic )
+MYSPELL_THES=( ru_th_aot.{dat,idx} )
+
+inherit myspell-r2
+
+EXT="extensions"
+DICT="russian-dictionary-pack"
+MY_PN="dict_pack_ru-aot"
+MY_PV="0.4.3"
+
+DESCRIPTION="Russian spellcheck dictionary based on works of AOT group for myspell/hunspell"
+HOMEPAGE="https://extensions.libreoffice.org/extensions/russian-dictionary-pack"
+SRC_URI="https://extensions.libreoffice.org/${EXT}/${DICT}/0-4.3/@@download/file/${MY_PN}-${MY_PV//./-}.oxt"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux"
+
+src_prepare() {
+ default
+ mv russian-aot.dic ru_RU.dic || die
+ mv russian-aot.aff ru_RU.aff || die
+}