summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-dicts/verbiste
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-dicts/verbiste')
-rw-r--r--app-dicts/verbiste/Manifest1
-rw-r--r--app-dicts/verbiste/metadata.xml8
-rw-r--r--app-dicts/verbiste/verbiste-0.1.38-r1.ebuild69
3 files changed, 78 insertions, 0 deletions
diff --git a/app-dicts/verbiste/Manifest b/app-dicts/verbiste/Manifest
new file mode 100644
index 000000000000..a2cf3d63bb64
--- /dev/null
+++ b/app-dicts/verbiste/Manifest
@@ -0,0 +1 @@
+DIST verbiste-0.1.38.tar.gz 706222 SHA256 7be13f0cc5c415ea5382ed2ee4391c21c700910eef2771086a28e44ff32817ff SHA512 b5d99d08a9d1a7c91c1dbb86e0d4465a46403db881cd28d2abaf8d376adef6b4d4f5ac93e528d45beb639b77aff7e1730dbb436624674ff21c1f5781173db787 WHIRLPOOL 9e7558e36c33eb7cd89f0cb888c01fb6040292ff7cdaeecd6f9ee51c7354939d5b9d23f769c67462be613abf0e275ab5580539a10fb5d0d8e8eca3489f16b027
diff --git a/app-dicts/verbiste/metadata.xml b/app-dicts/verbiste/metadata.xml
new file mode 100644
index 000000000000..c62c7f572390
--- /dev/null
+++ b/app-dicts/verbiste/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>eva@gentoo.org</email>
+ </maintainer>
+ <longdescription>French conjugation system including an option gnome front-end</longdescription>
+</pkgmetadata>
diff --git a/app-dicts/verbiste/verbiste-0.1.38-r1.ebuild b/app-dicts/verbiste/verbiste-0.1.38-r1.ebuild
new file mode 100644
index 000000000000..eb7e91835031
--- /dev/null
+++ b/app-dicts/verbiste/verbiste-0.1.38-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils gnome2-utils fdo-mime
+
+DESCRIPTION="French conjugation system"
+HOMEPAGE="http://sarrazip.com/dev/verbiste.html"
+SRC_URI="http://sarrazip.com/dev/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc x86"
+
+IUSE="gtk"
+
+RDEPEND="
+ >=dev-libs/libxml2-2.4.0:2
+ gtk? ( >=x11-libs/gtk+-2.6:2 )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ econf \
+ --with-console-app \
+ --without-gnome-app \
+ --without-gnome-applet \
+ $(use_with gtk gtk-app)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+ dodoc HACKING LISEZMOI
+ # file is only installed with USE=gnome
+ if use gtk; then
+ sed -e 's/Exec=.*/Exec=verbiste-gtk/' \
+ -i src/gnome/verbiste.desktop || die
+ insinto usr/share/applications
+ doins src/gnome/verbiste.desktop
+ fi
+}
+
+pkg_preinst() {
+ if use gtk; then
+ gnome2_icon_savelist
+ fi
+}
+
+pkg_postinst() {
+ if use gtk; then
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+ fi
+}
+
+pkg_postrm() {
+ if use gtk; then
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+ fi
+}