summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErik Quaeghebeur <gentoo@e3q.eu>2022-09-26 06:50:41 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-09-27 14:42:39 +0300
commit12027621555a33241b3d3c9280af332dff9ec67c (patch)
tree44107772d726fea1b1969b3c6cb98282bff7a248 /app-dicts
parentnet-libs/libiio: Add missing use dep (diff)
downloadgentoo-12027621555a33241b3d3c9280af332dff9ec67c.tar.gz
gentoo-12027621555a33241b3d3c9280af332dff9ec67c.tar.bz2
gentoo-12027621555a33241b3d3c9280af332dff9ec67c.zip
app-dicts/myspell-fr: add corrected 7.0 version as r1 revision
Signed-off-by: Erik Quaeghebeur <gentoo@e3q.eu> Closes: https://bugs.gentoo.org/607084 Closes: https://github.com/gentoo/gentoo/pull/27469 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/myspell-fr/Manifest1
-rw-r--r--app-dicts/myspell-fr/metadata.xml6
-rw-r--r--app-dicts/myspell-fr/myspell-fr-7.0-r1.ebuild73
3 files changed, 79 insertions, 1 deletions
diff --git a/app-dicts/myspell-fr/Manifest b/app-dicts/myspell-fr/Manifest
index 6a469d2ba26b..d9945bc8f2d6 100644
--- a/app-dicts/myspell-fr/Manifest
+++ b/app-dicts/myspell-fr/Manifest
@@ -1 +1,2 @@
+DIST lo-oo-ressources-linguistiques-fr-v7.0.oxt 3231859 BLAKE2B 779ab784e8c654a09ad54a166ae61b6eb61a5e5ba81828e33db9d7980c7ebe03f4b80bdcbbf52f9a448e550c4ffa918221933935f4893860887e5fc78d4c1b59 SHA512 ef4828660839f238efeb6092ae8a0735383d4b88015bab2f26b150ce21c3bee92442bf5d6e9fd08fea3d4ece3afbc97057b0d126dac666611cfae12c1bada703
DIST myspell-fr-7.0.tar.gz 3537269 BLAKE2B 4ed449860ed5c62ebe0669c513160c9380cb791f4eb0a4b9b8fb21ee6a0a845aabf3af1533a540d1697a2b9d980fc42a6ee60841da8149ba970eb34edd2f4e8a SHA512 af96495d8970d79283908226adc638a4cd387c94361bc9533df309a063eef53b625650ef5d899604b39cf6a2e97fcdc2200c914a252af425d55e4d076ce14ea7
diff --git a/app-dicts/myspell-fr/metadata.xml b/app-dicts/myspell-fr/metadata.xml
index c3bda71eefca..70e5090ff2f8 100644
--- a/app-dicts/myspell-fr/metadata.xml
+++ b/app-dicts/myspell-fr/metadata.xml
@@ -2,5 +2,9 @@
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<!-- maintainer-needed -->
- <stabilize-allarches/>
+ <stabilize-allarches />
+ <upstream>
+ <doc lang="fr">https://grammalecte.net/documentation.php?prj=fr</doc>
+ <bugs-to>https://grammalecte.net/forum.php?prj=fr</bugs-to>
+ </upstream>
</pkgmetadata>
diff --git a/app-dicts/myspell-fr/myspell-fr-7.0-r1.ebuild b/app-dicts/myspell-fr/myspell-fr-7.0-r1.ebuild
new file mode 100644
index 000000000000..c62d63e493b9
--- /dev/null
+++ b/app-dicts/myspell-fr/myspell-fr-7.0-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MYSPELL_DICT=(
+ # Classique (the recommended variant)
+ # FR region hack to deal with LibreOffice bug, see src_prepare
+ "fr_FR.aff"
+ "fr_FR.dic"
+ # Reforme 1990 = the reformed orthography
+ "fr-1990.aff"
+ "fr-1990.dic"
+ # Toutes variantes = Classique + Reforme
+ "fr-ttsvars.aff"
+ "fr-ttsvars.dic"
+)
+
+MYSPELL_HYPH=(
+ # FR region hack to deal with LibreOffice bug, see src_prepare
+ "hyph_fr_FR.dic"
+)
+
+MYSPELL_THES=(
+ # FR region hack to deal with LibreOffice bug, see src_prepare
+ "th_fr_FR_v2.dat"
+ "th_fr_FR_v2.idx"
+)
+
+inherit myspell-r2
+
+DESCRIPTION="French dictionaries for myspell/hunspell"
+HOMEPAGE="http://www.dicollecte.org/home.php?prj=fr"
+SRC_URI="http://www.dicollecte.org/grammalecte/oxt/lo-oo-ressources-linguistiques-fr-v${PV}.oxt"
+
+LICENSE="MPL-2.0 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x86-linux"
+IUSE=""
+
+src_prepare() {
+ # Renaming so that variant subtags follow bcp47 rules
+ # <https://tools.ietf.org/html/rfc5646#section-2.1>,
+ # as this gives a nicer presentation in Firefox
+ # (due to it following bcp47 rules)
+ #
+ # fr-classique is recommended so rename to fr
+ mv fr-classique.aff fr.aff || die
+ mv fr-classique.dic fr.dic || die
+ # fr-reforme1990 changed to fr-1990 similarly to de-1901 and de-1996
+ mv fr-reforme1990.aff fr-1990.aff || die
+ mv fr-reforme1990.dic fr-1990.dic || die
+ # fr-toutesvariantes changed to fr-ttsvars until we find something better
+ mv fr-toutesvariantes.aff fr-ttsvars.aff || die
+ mv fr-toutesvariantes.dic fr-ttsvars.dic || die
+
+ # To deal with LibreOffice bug
+ # https://bugs.documentfoundation.org/show_bug.cgi?id=64830
+ # we need dictionary/thesaurus/hyphenation files named fr_FR
+ # (or should that be fr-FR?), so we rename the recommended one fr here.
+ # This is hopefully temporary, so we keep this separate from
+ # the bcp47-ification above.
+ mv fr.aff fr_FR.aff || die
+ mv fr.dic fr_FR.dic || die
+ mv hyph_fr.dic hyph_fr_FR.dic || die
+ # thes -> th and extra v2 suffix, again to appease LibreOffice
+ mv thes_fr.dat th_fr_FR_v2.dat || die
+ mv thes_fr.idx th_fr_FR_v2.idx || die
+
+ eapply_user
+}
+
+DOCS=( package-description.txt README_dict_fr.txt README_hyph_fr-2.9.txt README_hyph_fr-3.0.txt README_thes_fr.txt )