summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-06-15 14:54:51 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-06-16 08:30:28 +0300
commit1956c7340d53fddd73e81a78cc1380cf74d10d50 (patch)
treebfcc092afe087929ea62b5bc35f852439a9332f3 /app-dicts
parentdev-ruby/rails: add 6.0.4 (diff)
downloadgentoo-1956c7340d53fddd73e81a78cc1380cf74d10d50.tar.gz
gentoo-1956c7340d53fddd73e81a78cc1380cf74d10d50.tar.bz2
gentoo-1956c7340d53fddd73e81a78cc1380cf74d10d50.zip
app-dicts/dictd-wn: install files into /usr/share
Closes: https://bugs.gentoo.org/790383 Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/21249 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/dictd-wn/dictd-wn-3.0_p33-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-dicts/dictd-wn/dictd-wn-3.0_p33-r1.ebuild b/app-dicts/dictd-wn/dictd-wn-3.0_p33-r1.ebuild
new file mode 100644
index 000000000000..b0efe465234d
--- /dev/null
+++ b/app-dicts/dictd-wn/dictd-wn-3.0_p33-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit unpacker
+
+DESCRIPTION="WordNet for dict"
+HOMEPAGE="https://wordnet.princeton.edu"
+SRC_URI="mirror://debian/pool/main/w/wordnet/dict-wn_${PV/_p/-}_all.deb"
+S="${WORKDIR}"
+LICENSE="Princeton"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND=">=app-text/dictd-1.5.5"
+
+src_unpack() {
+ unpack_deb ${A}
+}
+
+src_install() {
+ insinto /usr/share/dict
+ doins usr/share/dictd/{wn.dict.dz,wn.index}
+}