summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-12-16 23:13:04 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-12-16 23:26:53 +0100
commit7c5fe3706884e883dc8de4a36d99fdafba34fc60 (patch)
treee3e51d52c552e0b228e1fce6cc84f386f691f415 /app-dicts
parentapp-dicts/aspell-ro: drop 3.3.10 (diff)
downloadgentoo-7c5fe3706884e883dc8de4a36d99fdafba34fc60.tar.gz
gentoo-7c5fe3706884e883dc8de4a36d99fdafba34fc60.tar.bz2
gentoo-7c5fe3706884e883dc8de4a36d99fdafba34fc60.zip
app-dicts/aspell-ru: update EAPI 7 -> 8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/aspell-ru/aspell-ru-0.99.1-r2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-dicts/aspell-ru/aspell-ru-0.99.1-r2.ebuild b/app-dicts/aspell-ru/aspell-ru-0.99.1-r2.ebuild
new file mode 100644
index 000000000000..012c39f22db5
--- /dev/null
+++ b/app-dicts/aspell-ru/aspell-ru-0.99.1-r2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ASPELL_LANG="Russian"
+ASPELL_VERSION=6
+MY_PV="$(ver_cut 1-2)f7-$(ver_cut 3)"
+MY_P="${PN/aspell/aspell${ASPELL_VERSION}}-${MY_PV}"
+
+inherit aspell-dict-r1
+
+SRC_URI="mirror://gnu/${PN%-*}/dict/${PN/aspell-/}/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+
+src_prepare() {
+ default
+
+ # Setting default dictionary to ru-yeyo
+ cp -v ru-yeyo.multi ru.multi || die
+}