summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-doc/NaturalDocs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-doc/NaturalDocs')
-rw-r--r--app-doc/NaturalDocs/Manifest1
-rw-r--r--app-doc/NaturalDocs/NaturalDocs-1.52-r1.ebuild57
-rw-r--r--app-doc/NaturalDocs/metadata.xml23
3 files changed, 81 insertions, 0 deletions
diff --git a/app-doc/NaturalDocs/Manifest b/app-doc/NaturalDocs/Manifest
new file mode 100644
index 000000000000..383e63015c09
--- /dev/null
+++ b/app-doc/NaturalDocs/Manifest
@@ -0,0 +1 @@
+DIST NaturalDocs-1.52.zip 460793 SHA256 3f13c99e15778afe6c5555084a083f856e93567b31b08acd1fd81afb10082681 SHA512 45d79dd2bf55a8cb7356eb5321a8c99cbab9d69a4d9a97033737090df2bfd86ee7a058a03016646c7fd6f20daf6523b2d77cd2248a7503a6c5c22684f08431c1 WHIRLPOOL 11bd1d5ad3b96b5d116be3463c871c25f60837f1f2f866f9f8dcdfbc33cdfc051a582e5e1b81289685924a57de503026ad1bb44d6965d0f0cd6c94a91c7909ab
diff --git a/app-doc/NaturalDocs/NaturalDocs-1.52-r1.ebuild b/app-doc/NaturalDocs/NaturalDocs-1.52-r1.ebuild
new file mode 100644
index 000000000000..dd1547ee21fd
--- /dev/null
+++ b/app-doc/NaturalDocs/NaturalDocs-1.52-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit perl-module
+
+DESCRIPTION="Extensible, multi-language source code documentation generator"
+HOMEPAGE="http://www.naturaldocs.org/"
+SRC_URI="mirror://sourceforge/naturaldocs/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ~ppc64 sparc x86"
+
+IUSE=""
+
+RDEPEND="dev-lang/perl"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}"
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r Styles Info JavaScript
+
+ insinto /etc/${PN}
+ doins -r Config/*
+ dosym /etc/${PN} /usr/share/${PN}/Config
+
+ perl_set_version
+ insinto ${VENDOR_LIB}
+ doins -r Modules/NaturalDocs
+ dodir /usr/share/${PN}/Modules
+ dosym ${VENDOR_LIB}/NaturalDocs /usr/share/${PN}/Modules/NaturalDocs
+
+ exeinto /usr/share/${PN}
+ doexe ${PN}
+
+ # Symlink the Perl script into /usr/bin
+ dodir /usr/bin
+ dosym /usr/share/${PN}/${PN} /usr/bin/${PN}
+
+ # Documentation
+ dohtml -r Help/*
+ dosym /usr/share/doc/${PF}/html /usr/share/${PN}/Help
+}
+
+pkg_preinst() {
+ if [[ -e /usr/share/${PN}/Config && ! -L /usr/share/${PN}/Config ]] ; then
+ mkdir -p /etc/${PN}
+ mv /usr/share/${PN}/Config/* /etc/${PN}/
+ rm -rf /usr/share/${PN}/Config
+ fi
+}
diff --git a/app-doc/NaturalDocs/metadata.xml b/app-doc/NaturalDocs/metadata.xml
new file mode 100644
index 000000000000..4d6d672b2674
--- /dev/null
+++ b/app-doc/NaturalDocs/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription>
+ Natural Docs is an open-source, extensible, multi-language
+ documentation generator. It extracts specially formatted comments
+ from source code and builds HTML documentation from it. The syntax
+ is transparent so that the comments in the source code read just as
+ easily as the generated documentation. It also focuses on automation
+ and high-quality generated output.
+ </longdescription>
+ <maintainer>
+ <email>idella4@gentoo.org</email>
+ <name>Ian Delaney</name>
+ </maintainer>
+ <maintainer>
+ <email>titanofold@gentoo.org</email>
+ <name>Aaron W. Swenson</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">naturaldocs</remote-id>
+ </upstream>
+</pkgmetadata>