summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorneeshy <neeshy@tfwno.gf>2020-03-22 01:04:16 -0400
committerJoonas Niilola <juippis@gentoo.org>2020-04-05 10:17:54 +0300
commitc58e83a791143d8e947e893fe72ded0593e2b7f4 (patch)
treedeb7686fd97099d9d09c646988e77d354cc63edf /app-doc/cppman/cppman-0.4.9.ebuild
parentwww-misc/buku: Add version 4.3 (diff)
downloadgentoo-c58e83a791143d8e947e893fe72ded0593e2b7f4.tar.gz
gentoo-c58e83a791143d8e947e893fe72ded0593e2b7f4.tar.bz2
gentoo-c58e83a791143d8e947e893fe72ded0593e2b7f4.zip
app-doc/cppman: bump version to 0.4.9
Signed-off-by: Nima Sadeghi <neeshy@tfwno.gf> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-doc/cppman/cppman-0.4.9.ebuild')
-rw-r--r--app-doc/cppman/cppman-0.4.9.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-doc/cppman/cppman-0.4.9.ebuild b/app-doc/cppman/cppman-0.4.9.ebuild
new file mode 100644
index 000000000000..a124e60ffdd5
--- /dev/null
+++ b/app-doc/cppman/cppman-0.4.9.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="sqlite,threads(+)"
+
+DISTUTILS_SINGLE_IMPL=true
+
+inherit distutils-r1
+
+DESCRIPTION="C++ man pages for Linux, with source from cplusplus.com and cppreference.com"
+HOMEPAGE="https://github.com/aitjcize/cppman"
+LICENSE="GPL-3"
+
+SLOT="0"
+SRC_URI="https://github.com/aitjcize/cppman/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
+
+RDEPEND="
+ sys-apps/groff
+ $(python_gen_cond_dep '
+ dev-python/beautifulsoup:4[${PYTHON_MULTI_USEDEP}]
+ dev-python/html5lib[${PYTHON_MULTI_USEDEP}]
+ ')
+"
+
+# `./setup install` already installs docs
+DOCS=()