summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2020-02-10 18:58:30 +0100
committerUlrich Müller <ulm@gentoo.org>2020-02-10 19:00:22 +0100
commit504c4020b8aa80a8a391f493e6b38a23a9846c1c (patch)
tree70e01c2cda4c677d161c64600420c1b9d3175ff7 /app-doc/devmanual
parentdev-python/cheroot: Remove old versions (diff)
downloadgentoo-504c4020b8aa80a8a391f493e6b38a23a9846c1c.tar.gz
gentoo-504c4020b8aa80a8a391f493e6b38a23a9846c1c.tar.bz2
gentoo-504c4020b8aa80a8a391f493e6b38a23a9846c1c.zip
app-doc/devmanual: Update live ebuild, new snapshot.
Package-Manager: Portage-2.3.88, Repoman-2.3.20 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-doc/devmanual')
-rw-r--r--app-doc/devmanual/Manifest2
-rw-r--r--app-doc/devmanual/devmanual-0_pre20200207.ebuild (renamed from app-doc/devmanual/devmanual-0_pre20200203.ebuild)29
-rw-r--r--app-doc/devmanual/devmanual-9999.ebuild29
3 files changed, 21 insertions, 39 deletions
diff --git a/app-doc/devmanual/Manifest b/app-doc/devmanual/Manifest
index e42a05bf9fc5..192ea59eecd1 100644
--- a/app-doc/devmanual/Manifest
+++ b/app-doc/devmanual/Manifest
@@ -1,2 +1,2 @@
DIST devmanual-0_pre20141116.tar.gz 169936 BLAKE2B 9b01004750b9fce226fa6a965292d3ffaff0923f877da611743e39ee19077ea7fe0d21ff138853d3f79e4d4941026c30fcabf63c8903572ed7ba5d50d32c8dd5 SHA512 6af3f9a262bdb2ceb61ab195691dff4a850b22e8d1226e20ae3257c566b6cc913f756c8b90a40e8aa78b1242e78d24c4209a1d9cdb0706ae9b64c653544a028f
-DIST devmanual-0_pre20200203.tar.xz 163740 BLAKE2B 39d8173bc524213e7a6e81def4f1631ea0d2503540551982d07ef58f414b8a052e8a3a0d2426b5864e06fb24f1745af4dea57e418fcc5e52c558dc1da9ff4530 SHA512 f3fce9ba557515b89c5a875dc1e4e968eb3097776842026403e41ebe972c2e4e764303c729c5835466faaa2675fa361fe7e0512d7a8222d7d8b1202a9049f98e
+DIST devmanual-0_pre20200207.tar.xz 163940 BLAKE2B c6cf856a8f6c80b500466e27cc4106c070cff2dcf8c89d58c9ca90d03cb34a1e6a2048cb99364993f224f3497309fc24207dc44f9c14ece37c49aa602480dac0 SHA512 f6a88312e2030bf4d9fcf64bf1f38397087cb151aa41cd0c254cfc6251e4d5b291e3b361094a7c1d5fdb16e40c1702c0f0b7460ba230bfb217ad733f400c9089
diff --git a/app-doc/devmanual/devmanual-0_pre20200203.ebuild b/app-doc/devmanual/devmanual-0_pre20200207.ebuild
index 9762d86e4733..5146b9288cc5 100644
--- a/app-doc/devmanual/devmanual-0_pre20200203.ebuild
+++ b/app-doc/devmanual/devmanual-0_pre20200207.ebuild
@@ -29,35 +29,26 @@ BDEPEND="dev-libs/libxml2
PATCHES=( "${FILESDIR}"/${PN}-eclasses.patch )
src_compile() {
- emake build OFFLINE=$(usex offline 1 0)
- use offline || emake documents.js
+ emake OFFLINE=$(usex offline 1 0)
}
src_install() {
- # clean out XML/XSL before installing
- find . \( \
- -iname '*.xml' -o \
- -iname '*.dtd' -o \
- -iname '*.xsl' -o \
- -iname '*.svg' \) -delete || die
- rm -r bin xsl .git* LICENSE Makefile README.md || die
-
- local HTML_DOCS=( . )
- einstalldocs
+ emake OFFLINE=$(usex offline 1 0) \
+ DESTDIR="${D}" \
+ htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ install
local DOC_CONTENTS="In order to browse the Gentoo Development Guide in
offline mode, point your browser to the following url:
file://${EPREFIX}/usr/share/doc/${PF}/html/index.html"
+ if ! has_version app-doc/eclass-manpages; then
+ DOC_CONTENTS+="\\n\\nThe offline version of the devmanual does not
+ include the documentation for the eclasses. If you need it,
+ then emerge app-doc/eclass-manpages."
+ fi
readme.gentoo_create_doc
}
pkg_postinst() {
readme.gentoo_print_elog
- if ! has_version app-doc/eclass-manpages; then
- elog "The offline version of the devmanual does not include the"
- elog "documentation for the eclasses. If you need it, then emerge"
- elog "the following package:"
- elog
- elog "app-doc/eclass-manpages"
- fi
}
diff --git a/app-doc/devmanual/devmanual-9999.ebuild b/app-doc/devmanual/devmanual-9999.ebuild
index 1957ff9c99ef..7bea70d1e20b 100644
--- a/app-doc/devmanual/devmanual-9999.ebuild
+++ b/app-doc/devmanual/devmanual-9999.ebuild
@@ -29,35 +29,26 @@ BDEPEND="dev-libs/libxml2
PATCHES=( "${FILESDIR}"/${PN}-eclasses.patch )
src_compile() {
- emake build OFFLINE=$(usex offline 1 0)
- use offline || emake documents.js
+ emake OFFLINE=$(usex offline 1 0)
}
src_install() {
- # clean out XML/XSL before installing
- find . \( \
- -iname '*.xml' -o \
- -iname '*.dtd' -o \
- -iname '*.xsl' -o \
- -iname '*.svg' \) -delete || die
- rm -r bin xsl .git* LICENSE Makefile README.md || die
-
- local HTML_DOCS=( . )
- einstalldocs
+ emake OFFLINE=$(usex offline 1 0) \
+ DESTDIR="${D}" \
+ htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ install
local DOC_CONTENTS="In order to browse the Gentoo Development Guide in
offline mode, point your browser to the following url:
file://${EPREFIX}/usr/share/doc/${PF}/html/index.html"
+ if ! has_version app-doc/eclass-manpages; then
+ DOC_CONTENTS+="\\n\\nThe offline version of the devmanual does not
+ include the documentation for the eclasses. If you need it,
+ then emerge app-doc/eclass-manpages."
+ fi
readme.gentoo_create_doc
}
pkg_postinst() {
readme.gentoo_print_elog
- if ! has_version app-doc/eclass-manpages; then
- elog "The offline version of the devmanual does not include the"
- elog "documentation for the eclasses. If you need it, then emerge"
- elog "the following package:"
- elog
- elog "app-doc/eclass-manpages"
- fi
}