summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2016-02-27 21:57:04 -0600
committerMatthias Maier <tamiko@gentoo.org>2016-02-27 21:57:04 -0600
commit697f3bfe5db06f0d251ac88dd4f67e92b1373b6c (patch)
treea0fdbdae5a0bcbf2e684c827a3df626feaf77fc4 /app-doc/doxygen/files
parentapp-doc/doxygen: remove unnecessary RESTRICT="mirror", bug #564712 (diff)
downloadgentoo-697f3bfe5db06f0d251ac88dd4f67e92b1373b6c.tar.gz
gentoo-697f3bfe5db06f0d251ac88dd4f67e92b1373b6c.tar.bz2
gentoo-697f3bfe5db06f0d251ac88dd4f67e92b1373b6c.zip
app-doc/doxygen: bump to 1.8.11, fix lingua support (bug #566510), EAPI 5, qt5
- Version bump to newly released 1.8.11. - Change EAPI to 5. - Switch Qt support (for doxywizard) to Qt5. - Fix LINGUAS support - Update live ebuild Gentoo-Bugs: 566510 Package-Manager: portage-2.2.26
Diffstat (limited to 'app-doc/doxygen/files')
-rw-r--r--app-doc/doxygen/files/doxygen-1.8.11-link_with_pthread.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-doc/doxygen/files/doxygen-1.8.11-link_with_pthread.patch b/app-doc/doxygen/files/doxygen-1.8.11-link_with_pthread.patch
new file mode 100644
index 000000000000..cdc630c4d42b
--- /dev/null
+++ b/app-doc/doxygen/files/doxygen-1.8.11-link_with_pthread.patch
@@ -0,0 +1,32 @@
+diff --git a/addon/doxysearch/CMakeLists.txt b/addon/doxysearch/CMakeLists.txt
+index 33e01c1..165fc3e 100644
+--- a/addon/doxysearch/CMakeLists.txt
++++ b/addon/doxysearch/CMakeLists.txt
+@@ -20,6 +20,7 @@ target_link_libraries(doxyindexer
+ ${ZLIB_LIBRARIES}
+ ${WIN_EXTRA_LIBS}
+ qtools
++ pthread
+ )
+
+ add_executable(doxysearch.cgi
+@@ -29,6 +30,7 @@ target_link_libraries(doxysearch.cgi
+ ${XAPIAN_LIBRARIES}
+ ${ZLIB_LIBRARIES}
+ ${WIN_EXTRA_LIBS}
++ pthread
+ )
+
+ install(TARGETS doxyindexer doxysearch.cgi DESTINATION bin)
+diff --git a/addon/doxywizard/CMakeLists.txt b/addon/doxywizard/CMakeLists.txt
+index bf2eda8..8eb2a1c 100644
+--- a/addon/doxywizard/CMakeLists.txt
++++ b/addon/doxywizard/CMakeLists.txt
+@@ -109,6 +109,7 @@ ${doxywizard_RESOURCES_RCC}
+ qt_use_modules(doxywizard Core Gui Widgets Xml)
+ target_link_libraries(doxywizard
+ ${QT_LIBRARIES} ${QT_QTMAIN_LIBRARY}
++pthread
+ )
+
+ install(TARGETS doxywizard DESTINATION bin)