summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2020-03-16 16:19:37 +0100
committerGuilherme Amadio <amadio@gentoo.org>2020-03-16 17:58:48 +0100
commitee0f47f0118320e974043cf90524e638a3b5cff0 (patch)
tree5cba2fb0ac4947f64d139a75f5df1e7355880c0b /app-doc/geant-docs/geant-docs-4.10.6.ebuild
parentapp-doc/geant-docs: add myself as maintainer (diff)
downloadgentoo-ee0f47f0118320e974043cf90524e638a3b5cff0.tar.gz
gentoo-ee0f47f0118320e974043cf90524e638a3b5cff0.tar.bz2
gentoo-ee0f47f0118320e974043cf90524e638a3b5cff0.zip
app-doc/geant-docs: version bump: 4.10.5_p2, 4.10.6
Note that documentation revisions and Geant4 revisions are not the same. The version 4.10.5_p2 is for updated documentation for Geant4 10.5, while 4.10.6 is the same for Geant4.10.6 as well as _p1. I am also updating the versioning in the ebuilds to remove the extra zeros, as only the tarballs from upstream use them. Versioned PDFs for the latest as well as for other versions have been added to the website upon my request, so I am switching all new ebuilds to use versioned files in SRC_URI. Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'app-doc/geant-docs/geant-docs-4.10.6.ebuild')
-rw-r--r--app-doc/geant-docs/geant-docs-4.10.6.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-doc/geant-docs/geant-docs-4.10.6.ebuild b/app-doc/geant-docs/geant-docs-4.10.6.ebuild
new file mode 100644
index 000000000000..5a524d841beb
--- /dev/null
+++ b/app-doc/geant-docs/geant-docs-4.10.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV=V$(ver_cut 2-3)
+
+DESCRIPTION="User documentation for Geant4 physics simulation toolkit"
+HOMEPAGE="https://geant4.web.cern.ch/support/user_documentation"
+SRC_DOC="https://geant4-userdoc.web.cern.ch/geant4-userdoc/UsersGuides"
+SRC_URI="
+ ${SRC_DOC}/FAQ/BackupVersions/${MY_PV}/fo/BookFAQ.pdf
+ -> BookFAQ-${PV}.pdf
+ ${SRC_DOC}/ForApplicationDeveloper/BackupVersions/${MY_PV}/fo/BookForAppliDev.pdf
+ -> BookForApplicationDevelopers-${PV}.pdf
+ ${SRC_DOC}/ForToolkitDeveloper/BackupVersions/${MY_PV}/fo/BookForToolDev.pdf
+ -> BookForToolkitDevelopers-${PV}.pdf
+ ${SRC_DOC}/InstallationGuide/BackupVersions/${MY_PV}/fo/BookInstalGuide.pdf
+ -> Geant4InstallationGuide-${PV}.pdf
+ ${SRC_DOC}/IntroductionToGeant4/BackupVersions/${MY_PV}/fo/BookIntroToGeant4.pdf
+ -> IntroductionToGeant4-${PV}.pdf
+ ${SRC_DOC}/PhysicsListGuide/BackupVersions/${MY_PV}/fo/PhysicsListGuide.pdf
+ -> PhysicsListGuide-${PV}.pdf
+ ${SRC_DOC}/PhysicsReferenceManual/BackupVersions/${MY_PV}/fo/PhysicsReferenceManual.pdf
+ -> PhysicsReferenceManual-${PV}.pdf
+"
+
+LICENSE="geant4"
+SLOT="4"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+S="${DISTDIR}"
+
+src_install() {
+ local doc
+ for doc in *.pdf; do
+ newdoc ${doc} ${doc/-${PV}};
+ done
+}