summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2019-12-02 03:32:47 +0300
committerJoonas Niilola <juippis@gentoo.org>2019-12-07 14:47:06 +0200
commit13bedab8be4f2162092380debc8c4dbe82ce56ca (patch)
treefe86b9238a9d7f5c711f36a5375d94457be1da17 /app-doc/gimp-help/gimp-help-2.10.0.ebuild
parentnet-im/signal-desktop-bin: remove old version (diff)
downloadgentoo-13bedab8be4f2162092380debc8c4dbe82ce56ca.tar.gz
gentoo-13bedab8be4f2162092380debc8c4dbe82ce56ca.tar.bz2
gentoo-13bedab8be4f2162092380debc8c4dbe82ce56ca.zip
app-doc/gimp-help: 2.10.0 version bump
Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/13830 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-doc/gimp-help/gimp-help-2.10.0.ebuild')
-rw-r--r--app-doc/gimp-help/gimp-help-2.10.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-doc/gimp-help/gimp-help-2.10.0.ebuild b/app-doc/gimp-help/gimp-help-2.10.0.ebuild
new file mode 100644
index 000000000000..51258072104b
--- /dev/null
+++ b/app-doc/gimp-help/gimp-help-2.10.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-any-r1
+
+DESCRIPTION="GNU Image Manipulation Program help files"
+HOMEPAGE="https://docs.gimp.org/"
+SRC_URI="mirror://gimp/help/${P}.tar.bz2"
+
+LICENSE="FDL-1.2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+BDEPEND="${PYTHON_DEPS}
+ sys-devel/gettext
+"
+
+DEPEND="$(python_gen_any_dep 'dev-libs/libxml2[python,${PYTHON_USEDEP}]')
+ dev-libs/libxslt
+"
+
+src_configure() {
+ econf --without-gimp
+}
+
+src_compile() {
+ # see https://bugs.gentoo.org/677198
+ emake -j1
+}