summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-09-16 11:03:47 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-09-16 11:04:13 +0300
commit6bf0e2eae719f66a579a5fe363b2f504b34fc650 (patch)
treefe4d181a8ffc099c329087438ba6dc994f51dd80 /app-doc/gimp-help
parentlicenses: remove unused LogMeIn-2013 license, it's LogMeIn now (diff)
downloadgentoo-6bf0e2eae719f66a579a5fe363b2f504b34fc650.tar.gz
gentoo-6bf0e2eae719f66a579a5fe363b2f504b34fc650.tar.bz2
gentoo-6bf0e2eae719f66a579a5fe363b2f504b34fc650.zip
app-doc/gimp-help: return 2.8.2 ebuild
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-doc/gimp-help')
-rw-r--r--app-doc/gimp-help/Manifest1
-rw-r--r--app-doc/gimp-help/gimp-help-2.8.2.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-doc/gimp-help/Manifest b/app-doc/gimp-help/Manifest
index 037747728007..9024553a992c 100644
--- a/app-doc/gimp-help/Manifest
+++ b/app-doc/gimp-help/Manifest
@@ -1 +1,2 @@
DIST gimp-help-2.10.0.tar.bz2 187092180 BLAKE2B 29a7fbe3fcb6f3210aeda4bc514d7e0eeca05f9fabd3b9022c7ed1e5a9432876cc3bf530632648e2eb50509add4e387106d9705a1c17469e33496daec737d21b SHA512 2f6d5e7cf0c3b4960c92074ef02d51a1d089c148f6453a66e453a3084cdede280f72c6b77d35f66777adbda8aa273ec2a472fb538142e51bb263c3077eec473a
+DIST gimp-help-2.8.2.tar.bz2 158504580 BLAKE2B d0023a4290879f97e3365f1208427997d1facc09a7ed4ac0a274615e9eff378c9a4da0d7c5190bc24ad27c2b03d6c513003297d835562b0fa3e02685443d15e9 SHA512 3afdaa8b2f005d939d039d2e22c8306145e7b7acaca5ef89279998e87931e99d1fe607f1337f7796d667d5c6be456ba976b3c8a937c9dd6b1888d7158cfbed67
diff --git a/app-doc/gimp-help/gimp-help-2.8.2.ebuild b/app-doc/gimp-help/gimp-help-2.8.2.ebuild
new file mode 100644
index 000000000000..a4c033714438
--- /dev/null
+++ b/app-doc/gimp-help/gimp-help-2.8.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-any-r1
+
+DESCRIPTION="GNU Image Manipulation Program help files"
+HOMEPAGE="https://docs.gimp.org/"
+SRC_URI="mirror://gimp/help/${P}.tar.bz2"
+
+LICENSE="FDL-1.2"
+SLOT="2"
+KEYWORDS="~alpha amd64 ~hppa ~ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}
+ $(python_gen_any_dep 'dev-libs/libxml2[python,${PYTHON_USEDEP}]')
+ dev-libs/libxslt
+ sys-devel/gettext
+"
+
+python_check_deps() {
+ has_version "dev-libs/libxml2[${PYTHON_USEDEP}]"
+}
+
+src_configure() {
+ econf --without-gimp
+}
+
+src_compile() {
+ # see https://bugs.gentoo.org/677198
+ emake -j 1
+}