summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-doc/linux-kernel-in-a-nutshell
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-doc/linux-kernel-in-a-nutshell')
-rw-r--r--app-doc/linux-kernel-in-a-nutshell/Manifest2
-rw-r--r--app-doc/linux-kernel-in-a-nutshell/linux-kernel-in-a-nutshell-1.ebuild26
-rw-r--r--app-doc/linux-kernel-in-a-nutshell/metadata.xml8
3 files changed, 36 insertions, 0 deletions
diff --git a/app-doc/linux-kernel-in-a-nutshell/Manifest b/app-doc/linux-kernel-in-a-nutshell/Manifest
new file mode 100644
index 000000000000..c20dae327485
--- /dev/null
+++ b/app-doc/linux-kernel-in-a-nutshell/Manifest
@@ -0,0 +1,2 @@
+DIST lkn_pdf.tar.bz2 3533339 SHA256 3a27dac9f2319ede9e314de54604d13d2130b1931a39be8c02e7449b52b1e956 SHA512 5a0815148b379347675e2c8f71476e8e950a8028fd625044457773c4e7b62fb886edc7151a46a9dd0cba47729c99317f779974e395149d87c4c9483c7404ede0 WHIRLPOOL c130c01e97028c5477c5818c7a22e96a2f603f0df670351b11fb732b532ce0ea20ef9f1ef220aee446aa8a583b9e5d60a53e8a9b543c612c1fa567fc3bf9d2f9
+DIST lkn_xml.tar.bz2 1058278 SHA256 32c64058b704df54a83c755e707350654eebbb17ebe578e37411a4ec6bb7a06a SHA512 831b19f67b50f897f93720c19b7bbf90673c420c2b1ce257de3c656a01cb12ebee8499dc86c673cba9c14fb6fc50e644fbf84156d9d2580127affeabda87a83c WHIRLPOOL b90e49e876a8530d743e69b3b36b38f3c5a004a2fc2a16dd996059d148d4fe2599abb989ebd339b5191245b5a31174a3dbaf488b07f111f89e97bcde165915f6
diff --git a/app-doc/linux-kernel-in-a-nutshell/linux-kernel-in-a-nutshell-1.ebuild b/app-doc/linux-kernel-in-a-nutshell/linux-kernel-in-a-nutshell-1.ebuild
new file mode 100644
index 000000000000..4b3607b80a2b
--- /dev/null
+++ b/app-doc/linux-kernel-in-a-nutshell/linux-kernel-in-a-nutshell-1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="Linux Kernel in a Nutshell: A Desktop Quick Reference"
+HOMEPAGE="http://www.kroah.com/lkn/"
+SRC_URI="mirror://kernel/linux/kernel/people/gregkh/lkn/lkn_pdf.tar.bz2
+ mirror://kernel/linux/kernel/people/gregkh/lkn/lkn_xml.tar.bz2"
+
+LICENSE="CC-BY-SA-2.5"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86"
+IUSE=""
+
+DEPEND=""
+
+S=${WORKDIR}
+
+src_install() {
+ insinto /usr/share/doc/${PN}/pdf
+ doins -r lkn_pdf/* || die
+ insinto /usr/share/doc/${PN}/xml
+ doins -r lkn_xml/* || die
+}
diff --git a/app-doc/linux-kernel-in-a-nutshell/metadata.xml b/app-doc/linux-kernel-in-a-nutshell/metadata.xml
new file mode 100644
index 000000000000..a99561f3a9d8
--- /dev/null
+++ b/app-doc/linux-kernel-in-a-nutshell/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>gregkh@gentoo.org</email>
+ <name>Greg Kroah-Hartman</name>
+ </maintainer>
+</pkgmetadata>