summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-doc/tldp-howto/tldp-howto-20100701.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-doc/tldp-howto/tldp-howto-20100701.ebuild')
-rw-r--r--app-doc/tldp-howto/tldp-howto-20100701.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/app-doc/tldp-howto/tldp-howto-20100701.ebuild b/app-doc/tldp-howto/tldp-howto-20100701.ebuild
new file mode 100644
index 000000000000..5f73d47b693a
--- /dev/null
+++ b/app-doc/tldp-howto/tldp-howto-20100701.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit confutils
+
+DESCRIPTION="The Linux Documentation Project HOWTOs"
+HOMEPAGE="http://www.tldp.org"
+
+# Yay, unversioned distfiles
+# http://www.ibiblio.org/pub/Linux/docs/HOWTO/Linux-HOWTOs.tar.bz2
+# http://www.ibiblio.org/pub/Linux/docs/HOWTO/other-formats/html/Linux-html-HOWTOs.tar.bz2
+# ^^^ this also contains the pdfs, not sure if it's intentional as older versions don't
+# http://www.ibiblio.org/pub/Linux/docs/HOWTO/other-formats/html_single/Linux-html-single-HOWTOs.tar.bz2
+# http://www.ibiblio.org/pub/Linux/docs/HOWTO/other-formats/pdf/Linux-pdf-HOWTOs.tar.bz2
+
+SRC_URI="
+ html? ( mirror://gentoo/Linux-html-HOWTOs-${PV}.tar.bz2 )
+ htmlsingle? ( mirror://gentoo/Linux-html-single-HOWTOs-${PV}.tar.bz2 )
+ pdf? ( mirror://gentoo/Linux-pdf-HOWTOs-${PV}.tar.bz2 )
+ text? ( mirror://gentoo/Linux-HOWTOs-${PV}.tar.bz2 )"
+
+LICENSE="FDL-1.2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
+IUSE="+html htmlsingle pdf text"
+RESTRICT="binchecks strip"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ confutils_require_any html htmlsingle pdf text
+}
+
+src_unpack() {
+ mkdir -p "${S}"
+ cd "${S}"
+ if use text; then
+ mkdir "${S}"/text
+ pushd "${S}"/text > /dev/null
+ unpack Linux-HOWTOs-${PV}.tar.bz2
+ popd > /dev/null
+ fi
+ if use html; then
+ unpack Linux-html-HOWTOs-${PV}.tar.bz2
+ [[ -d ${S}/HOWTO/pdf ]] && rm -r "${S}"/HOWTO/pdf
+ mv "${S}"/HOWTO "${S}"/html
+ fi
+ if use htmlsingle; then
+ mkdir "${S}"/htmlsingle
+ pushd "${S}"/htmlsingle > /dev/null
+ unpack Linux-html-single-HOWTOs-${PV}.tar.bz2
+ popd > /dev/null
+ fi
+ if use pdf; then
+ mkdir "${S}"/pdf
+ pushd "${S}"/pdf > /dev/null
+ unpack Linux-pdf-HOWTOs-${PV}.tar.bz2
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ if use text; then
+ docinto text
+ dodoc "${S}"/text/*
+ rm -r "${S}"/text
+ fi
+ insinto /usr/share/doc/${PF}
+ doins -r "${S}"/*
+}