summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-06-16 15:49:55 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-06-16 15:50:41 +0200
commitecd03b6a389b6175ba047fc4412f46dbf60316ae (patch)
treeb255686e15e41555eee7d4435d4c36fb098a7d99 /app-doc/zeal/zeal-0.6.1.ebuild
parentapp-text/texlive-core: disable xindy-rules (diff)
downloadgentoo-ecd03b6a389b6175ba047fc4412f46dbf60316ae.tar.gz
gentoo-ecd03b6a389b6175ba047fc4412f46dbf60316ae.tar.bz2
gentoo-ecd03b6a389b6175ba047fc4412f46dbf60316ae.zip
app-doc/zeal: Fix build w/ Qt 5.15, use cmake.eclass, fix src_prepare
Closes: https://bugs.gentoo.org/728462 Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-doc/zeal/zeal-0.6.1.ebuild')
-rw-r--r--app-doc/zeal/zeal-0.6.1.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/app-doc/zeal/zeal-0.6.1.ebuild b/app-doc/zeal/zeal-0.6.1.ebuild
index 19114642c849..6fe0106f71ea 100644
--- a/app-doc/zeal/zeal-0.6.1.ebuild
+++ b/app-doc/zeal/zeal-0.6.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils xdg-utils
+inherit cmake xdg-utils
DESCRIPTION="Offline documentation browser inspired by Dash"
HOMEPAGE="https://zealdocs.org/"
@@ -12,7 +12,6 @@ SRC_URI="https://github.com/zealdocs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-
IUSE="vanilla"
DEPEND="
@@ -33,13 +32,16 @@ RDEPEND="
x11-themes/hicolor-icon-theme
"
+PATCHES=(
+ "${FILESDIR}/0001-libs-enforce-static-linking-of-internal-libs.patch"
+ "${FILESDIR}/${P}-qt-5.15.patch"
+)
+
src_prepare() {
- default
- eapply "${FILESDIR}/0001-libs-enforce-static-linking-of-internal-libs.patch"
if ! use vanilla; then
- eapply "${FILESDIR}/0002-settings-disable-checking-for-updates-by-default.patch"
+ PATCHES+=( "${FILESDIR}/0002-settings-disable-checking-for-updates-by-default.patch" )
fi
- cmake-utils_src_prepare
+ cmake_src_prepare
}
pkg_postinst() {