summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-05-06 17:17:24 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-05-06 17:18:55 +0300
commit3fdf5be75f3184aeef18273e70f553f7d390d6cc (patch)
tree6c24193c021802b5076a304c88be9ac136062e8b /app-doc
parentmedia-sound/mangler: support espeak-ng (diff)
downloadgentoo-3fdf5be75f3184aeef18273e70f553f7d390d6cc.tar.gz
gentoo-3fdf5be75f3184aeef18273e70f553f7d390d6cc.tar.bz2
gentoo-3fdf5be75f3184aeef18273e70f553f7d390d6cc.zip
app-doc/mathjax-docs: EAPI=8, enable py3.10
- add missing python_check_deps funciton - fix usage of old sphinx function - bump EAPI (file contents doesn't change at all) - enable py3.11 Closes: https://bugs.gentoo.org/720136 Closes: https://bugs.gentoo.org/832425 Closes: https://bugs.gentoo.org/829061 Closes: https://bugs.gentoo.org/889408 Closes: https://bugs.gentoo.org/896522 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/mathjax-docs/mathjax-docs-2.7.7.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/app-doc/mathjax-docs/mathjax-docs-2.7.7.ebuild b/app-doc/mathjax-docs/mathjax-docs-2.7.7.ebuild
index 09c46593386f..0ae6c89946c7 100644
--- a/app-doc/mathjax-docs/mathjax-docs-2.7.7.ebuild
+++ b/app-doc/mathjax-docs/mathjax-docs-2.7.7.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{9..10} pypy3 )
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
inherit python-any-r1 vcs-clean
COMMIT="9d711f40638202b02f2154d7f05ea35088ff9388"
@@ -24,13 +24,17 @@ BDEPEND="
')
"
-DOCS=(
- README.md
-)
+python_check_deps() {
+ python_has_version "dev-python/sphinx[${PYTHON_USEDEP}]" &&
+ python_has_version "dev-python/sphinx-rtd-theme[${PYTHON_USEDEP}]"
+}
+
+DOCS=( README.md )
src_prepare() {
default
egit_clean
+ sed -e 's/add_stylesheet/add_css_file/' -i conf.py || die
}
src_compile() {