summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-18 08:58:40 +0200
committerAaron W. Swenson <titanofold@gentoo.org>2019-07-18 08:55:59 -0400
commit893017730e5189c09ad38083286b7ee1ed2613b2 (patch)
tree99383a77144f823befdf40cc5a78173bfd5079e7 /app-doc
parentdev-vcs/fossil: Bump to 2.9 (diff)
downloadgentoo-893017730e5189c09ad38083286b7ee1ed2613b2.tar.gz
gentoo-893017730e5189c09ad38083286b7ee1ed2613b2.tar.bz2
gentoo-893017730e5189c09ad38083286b7ee1ed2613b2.zip
app-doc/gnucash-docs: Sanitize L10N handling
- remove L10N=C, C locale is now installed unconditionally - remove unused l10n.eclass - simplify the code Bug: https://bugs.gentoo.org/689474 Signed-off-by: Michał Górny <mgorny@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/12465 Closes: https://bugs.gentoo.org/689474 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/gnucash-docs/gnucash-docs-3.6-r1.ebuild (renamed from app-doc/gnucash-docs/gnucash-docs-3.6.ebuild)31
1 files changed, 6 insertions, 25 deletions
diff --git a/app-doc/gnucash-docs/gnucash-docs-3.6.ebuild b/app-doc/gnucash-docs/gnucash-docs-3.6-r1.ebuild
index 2fd86099fbde..505a73b78785 100644
--- a/app-doc/gnucash-docs/gnucash-docs-3.6.ebuild
+++ b/app-doc/gnucash-docs/gnucash-docs-3.6-r1.ebuild
@@ -3,10 +3,7 @@
EAPI=6
-PLOCALES="C de it ja pt ru"
-PLOCALE_BACKUP="C"
-
-inherit autotools gnome2 l10n
+inherit autotools gnome2
DESCRIPTION="Documentation package for GnuCash"
HOMEPAGE="http://www.gnucash.org/"
@@ -15,10 +12,8 @@ SRC_URI="https://github.com/Gnucash/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
SLOT="0"
LICENSE="GPL-2 FDL-1.1"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-
-for my_locale in ${PLOCALES}; do
- IUSE+=" l10n_${my_locale}"
-done
+LOCALES=( de it ja pt ru )
+IUSE="${LOCALES[*]/#/l10n_}"
DEPEND="
app-text/docbook-xml-dtd
@@ -28,18 +23,6 @@ DEPEND="
dev-libs/libxslt
"
-my_l10n_get_locales() {
- local l locales
- for l in ${PLOCALES[@]}; do
- use "l10n_${l}" && locales+=( $l )
- done
- if [[ ${#locales[@]} -gt 0 ]]; then
- echo ${locales[@]}
- else
- echo $PLOCALE_BACKUP
- fi
-}
-
src_prepare() {
default
eautoreconf
@@ -53,7 +36,7 @@ src_install() {
local doc_type my_lang
for doc_type in help guide; do
- for my_lang in $(my_l10n_get_locales); do
+ for my_lang in C ${L10N}; do
case $my_lang in
# Both help and guides translated
C|de|it|pt) ;;
@@ -61,7 +44,7 @@ src_install() {
if [[ ${doc_type} = "help" ]] ; then
elog "Help documentation hasn't been translated for $my_lang"
elog "Will do English instead."
- my_lang=C
+ continue
fi
;;
*)
@@ -69,12 +52,10 @@ src_install() {
;;
esac
- cd "${S}/${doc_type}/${my_lang}" || die
- emake DESTDIR="${D}" install
+ emake -C "${doc_type}/${my_lang}" DESTDIR="${D}" install
done
done
- cd "${S}" || die
einstalldocs
}