summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-11 08:57:43 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-11 09:04:36 +0100
commitb43a50d73da572ad333846ecf5e6776f1cfdaf26 (patch)
tree7fe3939343b8ad8249b005a1ae75cf73d7952de1 /app-doc
parentmedia-gfx/cairosvg: Bump to 2.4.2, py3.{7,8}, tests (diff)
downloadgentoo-b43a50d73da572ad333846ecf5e6776f1cfdaf26.tar.gz
gentoo-b43a50d73da572ad333846ecf5e6776f1cfdaf26.tar.bz2
gentoo-b43a50d73da572ad333846ecf5e6776f1cfdaf26.zip
Move {dev-python → app-doc}/ghp-import
This is merely a tool written in Python. It does not belong in dev-python/. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/ghp-import/Manifest1
-rw-r--r--app-doc/ghp-import/ghp-import-0.4.1-r1.ebuild32
-rw-r--r--app-doc/ghp-import/metadata.xml9
3 files changed, 42 insertions, 0 deletions
diff --git a/app-doc/ghp-import/Manifest b/app-doc/ghp-import/Manifest
new file mode 100644
index 000000000000..5d0b11ce15a9
--- /dev/null
+++ b/app-doc/ghp-import/Manifest
@@ -0,0 +1 @@
+DIST ghp-import-0.4.1.tar.gz 5002 BLAKE2B 667a40c0d852799e97d295df76d17d50017880afc9b2daa27d49444da84c791af619dea06b282e15c4d627a9584a23c2aa9fafcf45d9e0e924f9a6a966d071b6 SHA512 8b0e6578f05dc74449082a840ccd609a43fba3ca1c4dffacaddc4b27d2e9e3eac565a5c9672734e6ec5f2e8872b13ae0bb8a5d6bae4ee6c4cf41ef7d2c0b2eda
diff --git a/app-doc/ghp-import/ghp-import-0.4.1-r1.ebuild b/app-doc/ghp-import/ghp-import-0.4.1-r1.ebuild
new file mode 100644
index 000000000000..c6fb4d58de59
--- /dev/null
+++ b/app-doc/ghp-import/ghp-import-0.4.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="Copy your docs directly to the gh-pages branch"
+HOMEPAGE="https://github.com/davisp/ghp-import"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="tumbolia"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_prepare_all() {
+ ebegin 'patching setup.py'
+ sed \
+ -e '4ifrom codecs import open\n' \
+ -e '/LONG_DESC/s/))/), encoding = "utf-8")/' \
+ -i setup.py
+ STATUS=${?}
+ eend ${STATUS}
+ [[ ${STATUS} -gt 0 ]] && die
+
+ distutils-r1_python_prepare_all
+}
diff --git a/app-doc/ghp-import/metadata.xml b/app-doc/ghp-import/metadata.xml
new file mode 100644
index 000000000000..9bba96f1e08f
--- /dev/null
+++ b/app-doc/ghp-import/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!--maintainer-needed-->
+ <upstream>
+ <remote-id type="pypi">ghp-import</remote-id>
+ <remote-id type="github">davisp/ghp-import</remote-id>
+ </upstream>
+</pkgmetadata>