summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-27 04:05:07 +0100
committerSam James <sam@gentoo.org>2023-05-27 04:05:30 +0100
commitfc9a4259cd3050b1e94947dc2c9738bf29f62036 (patch)
tree5bcea65c79b0bc33833e31787ad1484150b5aa19 /app-doc
parentdev-libs/spdlog: fix build w/ musl-1.2.4 (diff)
downloadgentoo-fc9a4259cd3050b1e94947dc2c9738bf29f62036.tar.gz
gentoo-fc9a4259cd3050b1e94947dc2c9738bf29f62036.tar.bz2
gentoo-fc9a4259cd3050b1e94947dc2c9738bf29f62036.zip
app-doc/doxygen: fix build w/ musl-1.2.4
Closes: https://bugs.gentoo.org/906920 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/doxygen/doxygen-1.9.7-r1.ebuild1
-rw-r--r--app-doc/doxygen/doxygen-9999.ebuild1
-rw-r--r--app-doc/doxygen/files/doxygen-1.9.7-musl-1.2.4.patch26
3 files changed, 28 insertions, 0 deletions
diff --git a/app-doc/doxygen/doxygen-1.9.7-r1.ebuild b/app-doc/doxygen/doxygen-1.9.7-r1.ebuild
index 3d5cb989116b..367e877520b0 100644
--- a/app-doc/doxygen/doxygen-1.9.7-r1.ebuild
+++ b/app-doc/doxygen/doxygen-1.9.7-r1.ebuild
@@ -65,6 +65,7 @@ PATCHES=(
"${FILESDIR}/${PN}-1.9.4-link_with_pthread.patch"
"${FILESDIR}/${PN}-1.9.1-ignore-bad-encoding.patch"
"${FILESDIR}/${PN}-1.9.1-do_not_force_libcxx.patch"
+ "${FILESDIR}/${PN}-1.9.7-musl-1.2.4.patch"
)
DOCS=( LANGUAGE.HOWTO README.md )
diff --git a/app-doc/doxygen/doxygen-9999.ebuild b/app-doc/doxygen/doxygen-9999.ebuild
index 3d5cb989116b..367e877520b0 100644
--- a/app-doc/doxygen/doxygen-9999.ebuild
+++ b/app-doc/doxygen/doxygen-9999.ebuild
@@ -65,6 +65,7 @@ PATCHES=(
"${FILESDIR}/${PN}-1.9.4-link_with_pthread.patch"
"${FILESDIR}/${PN}-1.9.1-ignore-bad-encoding.patch"
"${FILESDIR}/${PN}-1.9.1-do_not_force_libcxx.patch"
+ "${FILESDIR}/${PN}-1.9.7-musl-1.2.4.patch"
)
DOCS=( LANGUAGE.HOWTO README.md )
diff --git a/app-doc/doxygen/files/doxygen-1.9.7-musl-1.2.4.patch b/app-doc/doxygen/files/doxygen-1.9.7-musl-1.2.4.patch
new file mode 100644
index 000000000000..2c71a0af9ae8
--- /dev/null
+++ b/app-doc/doxygen/files/doxygen-1.9.7-musl-1.2.4.patch
@@ -0,0 +1,26 @@
+https://bugs.gentoo.org/906920
+https://gitlab.exherbo.org/exherbo/arbor/-/commit/7b517ba0068adc471fe7b2ed8cfbb191a197ca17
+
+From 6d713aa98b36ee8219294515142c0225fbd09dfc Mon Sep 17 00:00:00 2001
+From: Heiko Becker <heirecka@exherbo.org>
+Date: Thu, 25 May 2023 10:52:29 +0200
+Subject: [PATCH] Apply upstream fix for spdlog
+
+Fixes the build with musl >= 1.2.4, see
+https://github.com/gabime/spdlog/commit/287a00d364990edbb621fe5e392aeb550135fb96
+for details.
+--- a/deps/spdlog/include/spdlog/details/os-inl.h
++++ b/deps/spdlog/include/spdlog/details/os-inl.h
+@@ -236,8 +236,8 @@ SPDLOG_INLINE size_t filesize(FILE *f)
+ # else
+ int fd = ::fileno(f);
+ # endif
+-// 64 bits(but not in osx or cygwin, where fstat64 is deprecated)
+-# if (defined(__linux__) || defined(__sun) || defined(_AIX)) && (defined(__LP64__) || defined(_LP64))
++// 64 bits(but not in osx, linux/musl or cygwin, where fstat64 is deprecated)
++# if ((defined(__linux__) && defined(__GLIBC__)) || defined(__sun) || defined(_AIX)) && (defined(__LP64__) || defined(_LP64))
+ struct stat64 st;
+ if (::fstat64(fd, &st) == 0)
+ {
+--
+2.41.0.rc2