summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2020-05-10 12:22:55 +0200
committerUlrich Müller <ulm@gentoo.org>2020-05-10 12:24:00 +0200
commit986be7e739caf0134614da3d1d647ae92c473a3b (patch)
treeca10e1aa17f4e8de8d4e48fca8276c6723336466 /app-editors/e3/files
parentapp-editors/fe: Call tc-getAR to determine the ar program. (diff)
downloadgentoo-986be7e739caf0134614da3d1d647ae92c473a3b.tar.gz
gentoo-986be7e739caf0134614da3d1d647ae92c473a3b.tar.bz2
gentoo-986be7e739caf0134614da3d1d647ae92c473a3b.zip
app-editors/e3: Call tc-getLD to determine the ld program.
Closes: https://bugs.gentoo.org/722050 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-editors/e3/files')
-rw-r--r--app-editors/e3/files/e3-2.8.2-makefile.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-editors/e3/files/e3-2.8.2-makefile.patch b/app-editors/e3/files/e3-2.8.2-makefile.patch
new file mode 100644
index 000000000000..5a22ff67e09d
--- /dev/null
+++ b/app-editors/e3/files/e3-2.8.2-makefile.patch
@@ -0,0 +1,36 @@
+--- e3-2.82-orig/Makefile
++++ e3-2.82/Makefile
+@@ -17,6 +17,8 @@
+ NASM_OR_YASM=nasm
+ #NASM_OR_YASM=yasm
+
++LD=ld
++
+ EXMODE=SED
+
+ #----------------------do not edit below line-------------------------------
+@@ -41,12 +43,12 @@
+
+ 32: $(ASOURCES) Makefile
+ ifeq ($(OS),LINUX)
+- nasm -O2 -f bin -l e3.lst -o e3 e3.asm -DCRIPLED_ELF=1 -D$(OS) -D$(EXMODE)
++ nasm -O2 -f bin -l e3.lst -o e3 e3.asm -DCRIPLED_ELF=1 -D$(OS)
+ chmod +x e3
+ else
+ echo $(ASVER)
+- nasm -O2 $(AFLAGS) -o e3.o e3.asm -l e3.lst -D$(OS) -D$(EXMODE)
+- ld -s -o e3 e3.o
++ nasm -O2 $(AFLAGS) -o e3.o e3.asm -l e3.lst -D$(OS)
++ $(LD) -s -o e3 e3.o
+ strip --remove-section .comment e3
+ endif
+ ln -sf e3 e3ws
+@@ -60,7 +62,7 @@
+ 64: $(ASOURCES) Makefile
+ cat e3.asm | sed -f e3_32to64.sed >e3.tmp
+ $(ASSEMBLER64)
+- ld -b elf64-x86-64 --oformat elf64-x86-64 -o e3 e3.o
++ $(LD) -b elf64-x86-64 --oformat elf64-x86-64 -o e3 e3.o
+ ifneq ($(DEBUG),true)
+ strip e3
+ endif