summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-editors/efte
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-editors/efte')
-rw-r--r--app-editors/efte/Manifest1
-rw-r--r--app-editors/efte/efte-1.1-r1.ebuild54
-rw-r--r--app-editors/efte/files/efte-1.1-desktopfile.patch18
-rw-r--r--app-editors/efte/files/efte-1.1-flags.patch15
-rw-r--r--app-editors/efte/metadata.xml10
5 files changed, 98 insertions, 0 deletions
diff --git a/app-editors/efte/Manifest b/app-editors/efte/Manifest
new file mode 100644
index 000000000000..c1206053d5d1
--- /dev/null
+++ b/app-editors/efte/Manifest
@@ -0,0 +1 @@
+DIST efte-1.1.tar.bz2 429919 SHA256 b71b9301dc781555bd9f4c73d7d81eb92701ccd5119b17da9b86ede402d31e16 SHA512 4dbfcaaadc56996d1b4659db2a82ec5132cf45b6f65ef545274769aa47f44ba27a8af1488ed57e5ffec2d9f5f1d1ef4cb9ee97514414796f176c2272a6bb6661 WHIRLPOOL 0d14d090767d55fb6d46d183e5ff9b43ecc9aacfe8171c63c1e15f0fc10bc562cde196cd06589515ba97429d195d2927df085b799c793a21dda0fee37d84190f
diff --git a/app-editors/efte/efte-1.1-r1.ebuild b/app-editors/efte/efte-1.1-r1.ebuild
new file mode 100644
index 000000000000..d5f320cc6179
--- /dev/null
+++ b/app-editors/efte/efte-1.1-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils cmake-utils fdo-mime
+
+DESCRIPTION="A fast text editor supporting folding, syntax highlighting, etc."
+HOMEPAGE="http://efte.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="|| ( GPL-2 Artistic )"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="gpm X"
+
+RDEPEND="sys-libs/ncurses
+ gpm? ( sys-libs/gpm )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXdmcp
+ x11-libs/libXau
+ media-fonts/font-misc-misc
+ )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-flags.patch \
+ "${FILESDIR}"/${P}-desktopfile.patch
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_build gpm)
+ $(cmake-utils_use_build X)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ rm -f "${D}"/usr/share/doc/${PN}/{COPYING,Artistic}
+ mv "${D}/usr/share/doc/${PN}" "${D}/usr/share/doc/${PF}" || die
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}
diff --git a/app-editors/efte/files/efte-1.1-desktopfile.patch b/app-editors/efte/files/efte-1.1-desktopfile.patch
new file mode 100644
index 000000000000..79cfc1c0ab34
--- /dev/null
+++ b/app-editors/efte/files/efte-1.1-desktopfile.patch
@@ -0,0 +1,18 @@
+--- efte-1.1/packaging/shared/efte.desktop
++++ efte-1.1/packaging/shared/efte.desktop
+@@ -1,6 +1,5 @@
+ [Desktop Entry]
+ Name=eFTE
+-Version=1.1
+ GenericName=Text Editor
+ GenericName[cz]=Textový editor
+ GenericName[de]=Texteditor
+@@ -29,7 +28,7 @@
+ Comment[sv]=Snabb, utbyggbar textredigerare för programmerare
+ MimeType=text/english;text/plain;text/x-makefile;text/x-c++hdr;text/x-c++src;text/x-chdr;text/x-csrc;text/x-java;text/x-pascal;text/x-tcl;text/x-tex;application/x-shellscript;text/x-c;text/x-c++;
+ Exec=efte %f
+-Icon=efte
++Icon=efte48x48
+ Type=Application
+ Terminal=false
+ Categories=Development;TextEditor;
diff --git a/app-editors/efte/files/efte-1.1-flags.patch b/app-editors/efte/files/efte-1.1-flags.patch
new file mode 100644
index 000000000000..10c17cff322c
--- /dev/null
+++ b/app-editors/efte/files/efte-1.1-flags.patch
@@ -0,0 +1,15 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Fri Jan 4 20:17:34 UTC 2013
+Subject: respect system CXXFLAGS
+
+--- efte-1.1/src/CMakeLists.txt
++++ efte-1.1/src/CMakeLists.txt
+@@ -86,7 +86,7 @@
+ ENDIF( UNIX AND ${CMAKE_SYSTEM_NAME} MATCHES "Darwin" )
+
+ IF( CMAKE_COMPILER_IS_GNUCC )
+- SET( CMAKE_CXX_FLAGS "-pedantic -Wall -Wno-long-long -Wpointer-arith -Wconversion -Wwrite-strings -Winline -fno-rtti -fno-exceptions" )
++ SET( CMAKE_CXX_FLAGS "-pedantic -Wall -Wno-long-long -Wpointer-arith -Wconversion -Wwrite-strings -Winline -fno-rtti -fno-exceptions ${CMAKE_CXX_FLAGS}" )
+ ENDIF( CMAKE_COMPILER_IS_GNUCC )
+
+ IF( CMAKE_SYSTEM_NAME MATCHES "HP/UX" )
diff --git a/app-editors/efte/metadata.xml b/app-editors/efte/metadata.xml
new file mode 100644
index 000000000000..1b5c6ecd9460
--- /dev/null
+++ b/app-editors/efte/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">efte</remote-id>
+ </upstream>
+</pkgmetadata>