summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2020-11-24 12:03:05 +0100
committerUlrich Müller <ulm@gentoo.org>2020-11-24 12:03:35 +0100
commit69c62ad248ca78ed2bb1833cae1ac20f63e9a0be (patch)
treef09f312eadf10295fc17ec0b94afa9184aaffb4e /app-editors/emacs
parentapp-editors/emacs: Use eapi8-dosym.eclass for relative symlinks. (diff)
downloadgentoo-69c62ad248ca78ed2bb1833cae1ac20f63e9a0be.tar.gz
gentoo-69c62ad248ca78ed2bb1833cae1ac20f63e9a0be.tar.bz2
gentoo-69c62ad248ca78ed2bb1833cae1ac20f63e9a0be.zip
app-editors/emacs: Install movemail setgid mail.
Package-Manager: Portage-3.0.10, Repoman-3.0.2 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-editors/emacs')
-rw-r--r--app-editors/emacs/emacs-23.4-r20.ebuild (renamed from app-editors/emacs/emacs-23.4-r19.ebuild)7
-rw-r--r--app-editors/emacs/emacs-24.5-r9.ebuild (renamed from app-editors/emacs/emacs-24.5-r8.ebuild)9
-rw-r--r--app-editors/emacs/emacs-25.3-r8.ebuild (renamed from app-editors/emacs/emacs-25.3-r7.ebuild)9
-rw-r--r--app-editors/emacs/emacs-26.3-r3.ebuild (renamed from app-editors/emacs/emacs-26.3-r2.ebuild)9
-rw-r--r--app-editors/emacs/emacs-27.1-r2.ebuild (renamed from app-editors/emacs/emacs-27.1-r1.ebuild)9
-rw-r--r--app-editors/emacs/emacs-27.1.9999-r1.ebuild9
-rw-r--r--app-editors/emacs/emacs-28.0.9999.ebuild9
7 files changed, 48 insertions, 13 deletions
diff --git a/app-editors/emacs/emacs-23.4-r19.ebuild b/app-editors/emacs/emacs-23.4-r20.ebuild
index a7ebc3b34702..7817b1255749 100644
--- a/app-editors/emacs/emacs-23.4-r19.ebuild
+++ b/app-editors/emacs/emacs-23.4-r20.ebuild
@@ -16,7 +16,8 @@ SLOT="23"
KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~mips ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="alsa aqua athena dbus games gconf gif gpm gtk gui gzip-el jpeg kerberos livecd m17n-lib motif png sound source svg tiff toolkit-scroll-bars Xaw3d xft +xpm"
-RDEPEND="app-emacs/emacs-common-gentoo[games?,gui(-)?]
+RDEPEND="acct-group/mail
+ app-emacs/emacs-common-gentoo[games?,gui(-)?]
net-libs/liblockfile
sys-libs/ncurses:0=
kerberos? ( virtual/krb5 )
@@ -249,6 +250,10 @@ src_install() {
touch "${ED}"/usr/share/info/${EMACS_SUFFIX}/.keepinfodir
docompress -x /usr/share/info/${EMACS_SUFFIX}/dir.orig
+ # movemail must be setgid mail
+ fowners root:mail /usr/libexec/emacs/${FULL_VERSION}/${CHOST}/movemail
+ fperms 2751 /usr/libexec/emacs/${FULL_VERSION}/${CHOST}/movemail
+
# avoid collision between slots, see bug #169033 e.g.
rm "${ED}"/usr/share/emacs/site-lisp/subdirs.el
rm -rf "${ED}"/usr/share/{applications,icons}
diff --git a/app-editors/emacs/emacs-24.5-r8.ebuild b/app-editors/emacs/emacs-24.5-r9.ebuild
index 19dd854cd077..d205fe64db89 100644
--- a/app-editors/emacs/emacs-24.5-r8.ebuild
+++ b/app-editors/emacs/emacs-24.5-r9.ebuild
@@ -15,7 +15,8 @@ SLOT="24"
KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~mips ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="acl alsa aqua athena dbus games gconf gfile gif gpm gsettings gtk gtk2 gui gzip-el imagemagick +inotify jpeg kerberos libxml2 livecd m17n-lib motif png selinux sound source ssl svg tiff toolkit-scroll-bars wide-int Xaw3d xft +xpm zlib"
-RDEPEND="app-emacs/emacs-common-gentoo[games?,gui(-)?]
+RDEPEND="acct-group/mail
+ app-emacs/emacs-common-gentoo[games?,gui(-)?]
net-libs/liblockfile
sys-libs/ncurses:0=
acl? ( virtual/acl )
@@ -229,7 +230,7 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" NO_BIN_LINK=t install
+ emake DESTDIR="${D}" NO_BIN_LINK=t BLESSMAIL_TARGET= install
mv "${ED}"/usr/bin/{emacs-${FULL_VERSION}-,}${EMACS_SUFFIX} \
|| die "moving emacs executable failed"
@@ -242,6 +243,10 @@ src_install() {
touch "${ED}"/usr/share/info/${EMACS_SUFFIX}/.keepinfodir
docompress -x /usr/share/info/${EMACS_SUFFIX}/dir.orig
+ # movemail must be setgid mail
+ fowners root:mail /usr/libexec/emacs/${FULL_VERSION}/${CHOST}/movemail
+ fperms 2751 /usr/libexec/emacs/${FULL_VERSION}/${CHOST}/movemail
+
# avoid collision between slots, see bug #169033 e.g.
rm "${ED}"/usr/share/emacs/site-lisp/subdirs.el
rm -rf "${ED}"/usr/share/{applications,icons}
diff --git a/app-editors/emacs/emacs-25.3-r7.ebuild b/app-editors/emacs/emacs-25.3-r8.ebuild
index d54d8a9d32f4..2deef88cebcf 100644
--- a/app-editors/emacs/emacs-25.3-r7.ebuild
+++ b/app-editors/emacs/emacs-25.3-r8.ebuild
@@ -15,7 +15,8 @@ SLOT="25"
KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="acl alsa aqua athena cairo dbus dynamic-loading games gconf gfile gif gpm gsettings gtk gtk2 gui gzip-el imagemagick +inotify jpeg kerberos libxml2 livecd m17n-lib motif png selinux sound source ssl svg tiff toolkit-scroll-bars wide-int Xaw3d xft +xpm zlib"
-RDEPEND="app-emacs/emacs-common-gentoo[games?,gui(-)?]
+RDEPEND="acct-group/mail
+ app-emacs/emacs-common-gentoo[games?,gui(-)?]
net-libs/liblockfile
sys-libs/ncurses:0=
acl? ( virtual/acl )
@@ -238,7 +239,7 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" NO_BIN_LINK=t install
+ emake DESTDIR="${D}" NO_BIN_LINK=t BLESSMAIL_TARGET= install
mv "${ED}"/usr/bin/{emacs-${FULL_VERSION}-,}${EMACS_SUFFIX} \
|| die "moving emacs executable failed"
@@ -251,6 +252,10 @@ src_install() {
touch "${ED}"/usr/share/info/${EMACS_SUFFIX}/.keepinfodir
docompress -x /usr/share/info/${EMACS_SUFFIX}/dir.orig
+ # movemail must be setgid mail
+ fowners root:mail /usr/libexec/emacs/${FULL_VERSION}/${CHOST}/movemail
+ fperms 2751 /usr/libexec/emacs/${FULL_VERSION}/${CHOST}/movemail
+
# avoid collision between slots, see bug #169033 e.g.
rm "${ED}"/usr/share/emacs/site-lisp/subdirs.el
rm -rf "${ED}"/usr/share/{appdata,applications,icons}
diff --git a/app-editors/emacs/emacs-26.3-r2.ebuild b/app-editors/emacs/emacs-26.3-r3.ebuild
index 764b1ea0cc7c..aac4c0527300 100644
--- a/app-editors/emacs/emacs-26.3-r2.ebuild
+++ b/app-editors/emacs/emacs-26.3-r3.ebuild
@@ -14,7 +14,8 @@ SLOT="26"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="acl alsa aqua athena cairo dbus dynamic-loading games gconf gfile gif gpm gsettings gtk gtk2 gui gzip-el imagemagick +inotify jpeg kerberos lcms libxml2 livecd m17n-lib mailutils motif png selinux sound source ssl svg systemd +threads tiff toolkit-scroll-bars wide-int Xaw3d xft +xpm xwidgets zlib"
-RDEPEND="app-emacs/emacs-common-gentoo[games?,gui(-)?]
+RDEPEND="acct-group/mail
+ app-emacs/emacs-common-gentoo[games?,gui(-)?]
sys-libs/ncurses:0=
acl? ( virtual/acl )
alsa? ( media-libs/alsa-lib )
@@ -256,7 +257,7 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" NO_BIN_LINK=t install
+ emake DESTDIR="${D}" NO_BIN_LINK=t BLESSMAIL_TARGET= install
mv "${ED}"/usr/bin/{emacs-${FULL_VERSION}-,}${EMACS_SUFFIX} || die
mv "${ED}"/usr/share/man/man1/{emacs-,}${EMACS_SUFFIX}.1 || die
@@ -267,6 +268,10 @@ src_install() {
touch "${ED}"/usr/share/info/${EMACS_SUFFIX}/.keepinfodir
docompress -x /usr/share/info/${EMACS_SUFFIX}/dir.orig
+ # movemail must be setgid mail
+ fowners root:mail /usr/libexec/emacs/${FULL_VERSION}/${CHOST}/movemail
+ fperms 2751 /usr/libexec/emacs/${FULL_VERSION}/${CHOST}/movemail
+
# avoid collision between slots, see bug #169033 e.g.
rm "${ED}"/usr/share/emacs/site-lisp/subdirs.el
rm -rf "${ED}"/usr/share/{appdata,applications,icons}
diff --git a/app-editors/emacs/emacs-27.1-r1.ebuild b/app-editors/emacs/emacs-27.1-r2.ebuild
index 2f899ce692e2..3023726c93ba 100644
--- a/app-editors/emacs/emacs-27.1-r1.ebuild
+++ b/app-editors/emacs/emacs-27.1-r2.ebuild
@@ -43,7 +43,8 @@ LICENSE="GPL-3+ FDL-1.3+ BSD HPND MIT W3C unicode PSF-2"
IUSE="acl alsa aqua athena cairo dbus dynamic-loading games gconf gfile gif +gmp gpm gsettings gtk gtk2 gui gzip-el harfbuzz imagemagick +inotify jpeg json kerberos lcms libxml2 livecd m17n-lib mailutils motif png selinux sound source ssl svg systemd +threads tiff toolkit-scroll-bars wide-int Xaw3d xft +xpm xwidgets zlib"
RESTRICT="test"
-RDEPEND="app-emacs/emacs-common-gentoo[games?,gui(-)?]
+RDEPEND="acct-group/mail
+ app-emacs/emacs-common-gentoo[games?,gui(-)?]
sys-libs/ncurses:0=
acl? ( virtual/acl )
alsa? ( media-libs/alsa-lib )
@@ -299,7 +300,7 @@ src_configure() {
#}
src_install() {
- emake DESTDIR="${D}" NO_BIN_LINK=t install
+ emake DESTDIR="${D}" NO_BIN_LINK=t BLESSMAIL_TARGET= install
mv "${ED}"/usr/bin/{emacs-${FULL_VERSION}-,}${EMACS_SUFFIX} || die
mv "${ED}"/usr/share/man/man1/{emacs-,}${EMACS_SUFFIX}.1 || die
@@ -310,6 +311,10 @@ src_install() {
touch "${ED}"/usr/share/info/${EMACS_SUFFIX}/.keepinfodir
docompress -x /usr/share/info/${EMACS_SUFFIX}/dir.orig
+ # movemail must be setgid mail
+ fowners root:mail /usr/libexec/emacs/${FULL_VERSION}/${CHOST}/movemail
+ fperms 2751 /usr/libexec/emacs/${FULL_VERSION}/${CHOST}/movemail
+
# avoid collision between slots, see bug #169033 e.g.
rm "${ED}"/usr/share/emacs/site-lisp/subdirs.el
rm -rf "${ED}"/usr/share/{appdata,applications,icons}
diff --git a/app-editors/emacs/emacs-27.1.9999-r1.ebuild b/app-editors/emacs/emacs-27.1.9999-r1.ebuild
index bd826f2edf16..d9bf716c2cbc 100644
--- a/app-editors/emacs/emacs-27.1.9999-r1.ebuild
+++ b/app-editors/emacs/emacs-27.1.9999-r1.ebuild
@@ -43,7 +43,8 @@ LICENSE="GPL-3+ FDL-1.3+ BSD HPND MIT W3C unicode PSF-2"
IUSE="acl alsa aqua athena cairo dbus dynamic-loading games gconf gfile gif +gmp gpm gsettings gtk gtk2 gui gzip-el harfbuzz imagemagick +inotify jpeg json kerberos lcms libxml2 livecd m17n-lib mailutils motif png selinux sound source ssl svg systemd +threads tiff toolkit-scroll-bars wide-int Xaw3d xft +xpm xwidgets zlib"
RESTRICT="test"
-RDEPEND="app-emacs/emacs-common-gentoo[games?,gui(-)?]
+RDEPEND="acct-group/mail
+ app-emacs/emacs-common-gentoo[games?,gui(-)?]
sys-libs/ncurses:0=
acl? ( virtual/acl )
alsa? ( media-libs/alsa-lib )
@@ -298,7 +299,7 @@ src_configure() {
#}
src_install() {
- emake DESTDIR="${D}" NO_BIN_LINK=t install
+ emake DESTDIR="${D}" NO_BIN_LINK=t BLESSMAIL_TARGET= install
mv "${ED}"/usr/bin/{emacs-${FULL_VERSION}-,}${EMACS_SUFFIX} || die
mv "${ED}"/usr/share/man/man1/{emacs-,}${EMACS_SUFFIX}.1 || die
@@ -309,6 +310,10 @@ src_install() {
touch "${ED}"/usr/share/info/${EMACS_SUFFIX}/.keepinfodir
docompress -x /usr/share/info/${EMACS_SUFFIX}/dir.orig
+ # movemail must be setgid mail
+ fowners root:mail /usr/libexec/emacs/${FULL_VERSION}/${CHOST}/movemail
+ fperms 2751 /usr/libexec/emacs/${FULL_VERSION}/${CHOST}/movemail
+
# avoid collision between slots, see bug #169033 e.g.
rm "${ED}"/usr/share/emacs/site-lisp/subdirs.el
rm -rf "${ED}"/usr/share/{appdata,applications,icons}
diff --git a/app-editors/emacs/emacs-28.0.9999.ebuild b/app-editors/emacs/emacs-28.0.9999.ebuild
index 478d84767fce..092c0181e57b 100644
--- a/app-editors/emacs/emacs-28.0.9999.ebuild
+++ b/app-editors/emacs/emacs-28.0.9999.ebuild
@@ -43,7 +43,8 @@ LICENSE="GPL-3+ FDL-1.3+ BSD HPND MIT W3C unicode PSF-2"
IUSE="acl alsa aqua athena cairo dbus dynamic-loading games gconf gfile gif +gmp gpm gsettings gtk gtk2 gui gzip-el harfbuzz imagemagick +inotify jpeg json kerberos lcms libxml2 livecd m17n-lib mailutils motif png selinux sound source ssl svg systemd +threads tiff toolkit-scroll-bars wide-int Xaw3d xft +xpm xwidgets zlib"
RESTRICT="test"
-RDEPEND="app-emacs/emacs-common-gentoo[games?,gui(-)?]
+RDEPEND="acct-group/mail
+ app-emacs/emacs-common-gentoo[games?,gui(-)?]
sys-libs/ncurses:0=
acl? ( virtual/acl )
alsa? ( media-libs/alsa-lib )
@@ -297,7 +298,7 @@ src_configure() {
#}
src_install() {
- emake DESTDIR="${D}" NO_BIN_LINK=t install
+ emake DESTDIR="${D}" NO_BIN_LINK=t BLESSMAIL_TARGET= install
mv "${ED}"/usr/bin/{emacs-${FULL_VERSION}-,}${EMACS_SUFFIX} || die
mv "${ED}"/usr/share/man/man1/{emacs-,}${EMACS_SUFFIX}.1 || die
@@ -308,6 +309,10 @@ src_install() {
touch "${ED}"/usr/share/info/${EMACS_SUFFIX}/.keepinfodir
docompress -x /usr/share/info/${EMACS_SUFFIX}/dir.orig
+ # movemail must be setgid mail
+ fowners root:mail /usr/libexec/emacs/${FULL_VERSION}/${CHOST}/movemail
+ fperms 2751 /usr/libexec/emacs/${FULL_VERSION}/${CHOST}/movemail
+
# avoid collision between slots, see bug #169033 e.g.
rm "${ED}"/usr/share/emacs/site-lisp/subdirs.el
rm -rf "${ED}"/usr/share/{appdata,applications,icons}