summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Stein <jstein@gentoo.org>2021-12-24 01:51:51 +0100
committerJonas Stein <jstein@gentoo.org>2021-12-24 01:51:51 +0100
commita1eafdab29fe35e1a1575efaf8eb377db075b659 (patch)
tree0d60983040b516832ac7f4eb1fdac823b67d8b0f /app-editors/ghex/ghex-9999.ebuild
parentsys-fs/fuse-overlayfs: Bump to version 1.8 (diff)
downloadgentoo-a1eafdab29fe35e1a1575efaf8eb377db075b659.tar.gz
gentoo-a1eafdab29fe35e1a1575efaf8eb377db075b659.tar.bz2
gentoo-a1eafdab29fe35e1a1575efaf8eb377db075b659.zip
app-editors/ghex: add live ebuild
Add a live ebuild for our users who support upstream during the transition. Bug: https://bugs.gentoo.org/829834 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Jonas Stein <jstein@gentoo.org>
Diffstat (limited to 'app-editors/ghex/ghex-9999.ebuild')
-rw-r--r--app-editors/ghex/ghex-9999.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-editors/ghex/ghex-9999.ebuild b/app-editors/ghex/ghex-9999.ebuild
new file mode 100644
index 000000000000..02e8fb9d1908
--- /dev/null
+++ b/app-editors/ghex/ghex-9999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="GNOME hexadecimal editor"
+HOMEPAGE="https://wiki.gnome.org/Apps/Ghex"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/ghex.git"
+ SRC_URI=""
+else
+ MY_PV="4.alpha.1"
+ SRC_URI="https://gitlab.gnome.org/GNOME/${PN}/-/archive/${MY_PV}/${PN}-${MY_PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~riscv ~x86 ~amd64-linux ~x86-linux"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+fi
+
+LICENSE="GPL-2+ FDL-1.1+"
+SLOT="4"
+
+RDEPEND="
+ >=dev-libs/atk-1.0.0
+ >=dev-libs/glib-2.31.10:2
+ >=x11-libs/gtk+-3.3.8:3
+ gui-libs/gtk:4
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}