summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-03-12 22:20:00 -0500
committerMatt Turner <mattst88@gentoo.org>2021-03-12 22:51:48 -0500
commit3b2a5e816668a0c0a85aacbfe87d733b88e81fbd (patch)
tree07bd9b0ac507e01b6459fb42bde2edb0ab727c11 /app-editors/gnome-latex
parentapp-accessibility/accerciser: Version bump to 3.38.0 (diff)
downloadgentoo-3b2a5e816668a0c0a85aacbfe87d733b88e81fbd.tar.gz
gentoo-3b2a5e816668a0c0a85aacbfe87d733b88e81fbd.tar.bz2
gentoo-3b2a5e816668a0c0a85aacbfe87d733b88e81fbd.zip
app-editors/gnome-latex: Version bump to 3.38.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-editors/gnome-latex')
-rw-r--r--app-editors/gnome-latex/Manifest1
-rw-r--r--app-editors/gnome-latex/gnome-latex-3.38.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/app-editors/gnome-latex/Manifest b/app-editors/gnome-latex/Manifest
index 209b5d27570e..800a2a47b618 100644
--- a/app-editors/gnome-latex/Manifest
+++ b/app-editors/gnome-latex/Manifest
@@ -1 +1,2 @@
DIST gnome-latex-3.36.0.tar.xz 1150308 BLAKE2B 7a0782b9be7727f700913b61f3ef3068340f69c2f88f5d8c1727fe7252230e194329a133f7d22a10ca4e3d2e471657705c1e821b0571b26a78a8fb13d6148d76 SHA512 54ba6c7571a0fe9cada9c8f01d57a1dd0bc4da07cc1a501adbc711433e6f16e890e44a588aa91b67f0ebb912dde8822d992763ed3b5a294a55a5bed20b7e1390
+DIST gnome-latex-3.38.0.tar.xz 1094376 BLAKE2B 0c02996dbac48c3859d33a0d504a64462e306d346ca22397820231fa8fe7ce2aa621a1435a02d78ea424fc8e9f5b7ac6e3e60180d8212c170d52eb4baee3b94a SHA512 c42cc1ff2c59afe4d995e9f13d9a858e2297827d5f9359cecd969d305224fc4b4d0306e0ab6aa1d9b7fc92acc25e597319299afe176cff1903f734fbc2ddf29b
diff --git a/app-editors/gnome-latex/gnome-latex-3.38.0.ebuild b/app-editors/gnome-latex/gnome-latex-3.38.0.ebuild
new file mode 100644
index 000000000000..a473957b2ef3
--- /dev/null
+++ b/app-editors/gnome-latex/gnome-latex-3.38.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome2
+
+DESCRIPTION="Integrated LaTeX environment for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/GNOME-LaTeX"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection +latexmk rubber"
+
+DEPEND="
+ >=app-text/gspell-1.8:0=
+ >=dev-libs/glib-2.56:2
+ >=dev-libs/libgee-0.10:0.8=
+ gnome-base/gsettings-desktop-schemas
+ >=x11-libs/gtk+-3.22:3
+ >=x11-libs/gtksourceview-4.0:4
+ >=gui-libs/amtk-5.2:5
+ >=gui-libs/tepl-5.0:5
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+ introspection? ( >=dev-libs/gobject-introspection-1.30.0:= )
+ gnome-base/dconf
+"
+RDEPEND="${DEPEND}
+ virtual/latex-base
+ x11-themes/hicolor-icon-theme
+ latexmk? ( dev-tex/latexmk )
+ rubber? ( dev-tex/rubber )
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.14
+ >=dev-util/intltool-0.50.1
+ dev-util/itstool
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ --enable-dconf_migration \
+ APPSTREAM_UTIL="$(type -P true)" # Fails strict validation in 3.32.0
+}