summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-12-23 11:22:55 +0100
committerPacho Ramos <pacho@gentoo.org>2015-12-23 11:58:38 +0100
commitfb59d3dd0f48704b8386be2af79a6b6074797a78 (patch)
tree2b4c3025f567ce3a35211eab190d2ab08fc9ff42 /app-editors/gobby
parentnet-libs/obby: Fix building with latest glibmm/libsigc++, use USE zeroconf in... (diff)
downloadgentoo-fb59d3dd0f48704b8386be2af79a6b6074797a78.tar.gz
gentoo-fb59d3dd0f48704b8386be2af79a6b6074797a78.tar.bz2
gentoo-fb59d3dd0f48704b8386be2af79a6b6074797a78.zip
app-editors/gobby: Fix building with latest glibmm/libsigc++, use USE zeroconf instead of avahi (#477620)
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-editors/gobby')
-rw-r--r--app-editors/gobby/gobby-0.4.13-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-editors/gobby/gobby-0.4.13-r1.ebuild b/app-editors/gobby/gobby-0.4.13-r1.ebuild
new file mode 100644
index 000000000000..f6a97b0d54c8
--- /dev/null
+++ b/app-editors/gobby/gobby-0.4.13-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils flag-o-matic
+
+DESCRIPTION="GTK-based collaborative editor"
+HOMEPAGE="http://gobby.0x539.de/"
+SRC_URI="http://releases.0x539.de/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gnome zeroconf"
+
+RDEPEND="
+ dev-cpp/glibmm:2
+ dev-cpp/gtkmm:2.4
+ dev-libs/libsigc++:2
+ >=net-libs/obby-0.4.6[zeroconf?]
+ dev-cpp/libxmlpp:2.6
+ x11-libs/gtksourceview:2.0
+ gnome? ( gnome-base/gnome-vfs )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+# There's only one test and it needs X
+RESTRICT="test"
+
+src_configure() {
+ append-cxxflags -std=c++11
+ econf \
+ --with-gtksourceview2 \
+ $(use_with gnome)
+}
+
+src_install() {
+ default
+ domenu contrib/gobby.desktop
+}