summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-09-15 00:30:02 -0400
committerTim Harder <radhermit@gentoo.org>2016-09-15 00:33:08 -0400
commitea536b92f5e1ec6b338b7c5946791fb90e05ab0c (patch)
tree0d4aa05c2434e55a52a7af43571b8e90ddb98b35 /app-editors/gvim/gvim-9999.ebuild
parentapp-editors/vim: version bump to 8.0.0004 (diff)
downloadgentoo-ea536b92f5e1ec6b338b7c5946791fb90e05ab0c.tar.gz
gentoo-ea536b92f5e1ec6b338b7c5946791fb90e05ab0c.tar.bz2
gentoo-ea536b92f5e1ec6b338b7c5946791fb90e05ab0c.zip
app-editors/gvim: version bump to 8.0.0004
Diffstat (limited to 'app-editors/gvim/gvim-9999.ebuild')
-rw-r--r--app-editors/gvim/gvim-9999.ebuild51
1 files changed, 32 insertions, 19 deletions
diff --git a/app-editors/gvim/gvim-9999.ebuild b/app-editors/gvim/gvim-9999.ebuild
index 7bdb32354021..19d0717ea81b 100644
--- a/app-editors/gvim/gvim-9999.ebuild
+++ b/app-editors/gvim/gvim-9999.ebuild
@@ -3,8 +3,8 @@
# $Id$
EAPI=6
-VIM_VERSION="7.4"
-PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+VIM_VERSION="8.0"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
PYTHON_REQ_USE=threads
inherit eutils vim-doc flag-o-matic fdo-mime versionator bash-completion-r1 prefix python-r1
@@ -23,7 +23,7 @@ HOMEPAGE="http://www.vim.org/ https://github.com/vim/vim"
SLOT="0"
LICENSE="vim"
-IUSE="acl aqua cscope debug gnome gtk lua luajit motif neXt netbeans nls perl python racket ruby selinux session tcl"
+IUSE="acl aqua cscope debug gnome gtk gtk3 lua luajit motif neXt netbeans nls perl python racket ruby selinux session tcl"
REQUIRED_USE="
luajit? ( lua )
python? (
@@ -37,20 +37,28 @@ RDEPEND="
~app-editors/vim-core-${PV}
>=app-eselect/eselect-vi-1.1
>=sys-libs/ncurses-5.2-r2:0=
+ x11-libs/libICE
+ x11-libs/libSM
x11-libs/libXext
x11-libs/libXt
acl? ( kernel_linux? ( sys-apps/acl ) )
!aqua? (
- gtk? (
- >=x11-libs/gtk+-2.6:2
+ gtk3? (
+ x11-libs/gtk+:3
x11-libs/libXft
- gnome? ( >=gnome-base/libgnomeui-2.6 )
)
- !gtk? (
- motif? ( >=x11-libs/motif-2.3:0 )
- !motif? (
- neXt? ( x11-libs/neXtaw )
- !neXt? ( x11-libs/libXaw )
+ !gtk3? (
+ gtk? (
+ >=x11-libs/gtk+-2.6:2
+ x11-libs/libXft
+ gnome? ( >=gnome-base/libgnomeui-2.6 )
+ )
+ !gtk? (
+ motif? ( >=x11-libs/motif-2.3:0 )
+ !motif? (
+ neXt? ( x11-libs/neXtaw )
+ !neXt? ( x11-libs/libXaw )
+ )
)
)
)
@@ -138,7 +146,7 @@ src_prepare() {
"${S}"/src/Makefile || die 'sed for ExtUtils-ParseXS failed'
fi
- default
+ eapply_user
}
src_configure() {
@@ -216,11 +224,12 @@ src_configure() {
# gvim's GUI preference order is as follows:
# aqua CARBON (not tested)
- # -aqua gtk gnome GNOME2
- # -aqua gtk -gnome GTK2
- # -aqua -gtk motif MOTIF
- # -aqua -gtk -motif neXt NEXTAW
- # -aqua -gtk -motif -neXt ATHENA
+ # -aqua gtk3 GTK3
+ # -aqua -gtk3 gnome GNOME2
+ # -aqua -gtk3 -gnome gtk GTK2
+ # -aqua -gtk -gtk3 motif MOTIF
+ # -aqua -gtk -gtk3 -motif neXt NEXTAW
+ # -aqua -gtk -gtk3 -motif -neXt ATHENA
echo ; echo
if use aqua ; then
einfo "Building gvim with the Carbon GUI"
@@ -228,6 +237,10 @@ src_configure() {
--enable-darwin
--enable-gui=carbon
)
+ elif use gtk3 ; then
+ myconf+=( --enable-gtk3-check )
+ einfo "Building gvim with the gtk+-3 GUI"
+ myconf+=( --enable-gui=gtk3 )
elif use gtk ; then
myconf+=( --enable-gtk2-check )
if use gnome ; then
@@ -249,10 +262,10 @@ src_configure() {
fi
echo ; echo
- # Let Portage do the stripping. Some people like that.
+ # let package manager strip binaries
export ac_cv_prog_STRIP="$(type -P true ) faking strip"
- # Keep Gentoo Prefix env contained within the EPREFIX
+ # keep prefix env contained within the EPREFIX
use prefix && myconf+=( --without-local-dir )
if [[ ${CHOST} == *-interix* ]]; then