summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2022-01-10 09:11:39 +0800
committerYixun Lan <dlan@gentoo.org>2022-01-10 09:25:05 +0800
commitf179242c56412b7f079bc351e135c9a70de0e3dd (patch)
treee348abddc69cd56d12b14c2ffd38b726af01d390 /app-editors/hexedit
parentprofiles: slotmove for sci-libs/opencascade (diff)
downloadgentoo-f179242c56412b7f079bc351e135c9a70de0e3dd.tar.gz
gentoo-f179242c56412b7f079bc351e135c9a70de0e3dd.tar.bz2
gentoo-f179242c56412b7f079bc351e135c9a70de0e3dd.zip
app-editors/hexedit: version bump, 1.5
EAPI=8 bump, live ebuild logic included Thanks 'jospezial' for contribution Closes: https://bugs.gentoo.org/751976 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'app-editors/hexedit')
-rw-r--r--app-editors/hexedit/Manifest1
-rw-r--r--app-editors/hexedit/hexedit-1.5.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-editors/hexedit/Manifest b/app-editors/hexedit/Manifest
index 792220b96ded..921b20e0546c 100644
--- a/app-editors/hexedit/Manifest
+++ b/app-editors/hexedit/Manifest
@@ -1 +1,2 @@
DIST hexedit-1.2.13.src.tgz 68778 BLAKE2B 377c4f0008f6e3b54e4cf2e0249fa344b684b11a6acea9daf7d8e6585524f9d11a4eb199d5289a57a72be5efbdf3060cc47269aad1d218784e7679a469ca4f50 SHA512 df9afb0b9b965e20ea8c427c1986b0200216601b157862199c35bae9e201ccc478ab0bfecd39d0dfaa85bf582f1cf372b0134fadcfeacf4734805a6e6dcaa2bb
+DIST hexedit-1.5.tar.gz 30544 BLAKE2B d7292a70819826fddd63f99ee9d05073b8a59f51477390af91151146ee1f5a75333560829f0351fa9e158ef932c07a3582a3e822f42e645917a7fa321055d14e SHA512 9d8e5c8c0cda0af17ffeaf528e3dacd7fc2878dfc0755cb055dae5c56f05c961353c1d1723b05897314b49a44a6eb96de5d3a599c6b29967425507eea7cc7ca5
diff --git a/app-editors/hexedit/hexedit-1.5.ebuild b/app-editors/hexedit/hexedit-1.5.ebuild
new file mode 100644
index 000000000000..7da44e6f5b51
--- /dev/null
+++ b/app-editors/hexedit/hexedit-1.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="View and edit files in hex or ASCII"
+HOMEPAGE="http://rigaux.org/hexedit.html"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+EGIT_REPO_URI="https://github.com/pixel/hexedit.git"
+else
+SRC_URI="https://github.com/pixel/hexedit/archive/${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="sys-libs/ncurses:="
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ dobin hexedit
+ doman hexedit.1
+ dodoc Changes
+}