summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-editors/jed
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-editors/jed')
-rw-r--r--app-editors/jed/Manifest1
-rw-r--r--app-editors/jed/jed-0.99.19.ebuild62
-rw-r--r--app-editors/jed/metadata.xml12
3 files changed, 75 insertions, 0 deletions
diff --git a/app-editors/jed/Manifest b/app-editors/jed/Manifest
new file mode 100644
index 000000000000..d1898d992ada
--- /dev/null
+++ b/app-editors/jed/Manifest
@@ -0,0 +1 @@
+DIST jed-0.99-19.tar.bz2 884198 SHA256 97a339ce2fb0a446767ee550786e6914fa2e8cdbad39a402e48368cd0d6b5763 SHA512 db8a30284f9b8e3e2c5d1a600eeb7af29c9f943a5c23d7c74fce926e0b0252f54805e214670e7c9357ce0e6918ad67cba2769a523979bfbd285328f94fff747c WHIRLPOOL 7ba51882004bdb9a59b2fffcc7c976f3a32bdb95247e6c3c8e3c423b0345af0a6eb74d4ed0a69831db160f7f69250a32f114dfb679a343eb002adee94a4ec987
diff --git a/app-editors/jed/jed-0.99.19.ebuild b/app-editors/jed/jed-0.99.19.ebuild
new file mode 100644
index 000000000000..7be18bd0f898
--- /dev/null
+++ b/app-editors/jed/jed-0.99.19.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit versionator
+
+MY_P=${PN}-$(replace_version_separator 2 '-')
+
+DESCRIPTION="Console S-Lang-based editor"
+HOMEPAGE="http://www.jedsoft.org/jed/"
+SRC_URI="ftp://space.mit.edu/pub/davis/jed/v${PV%.*}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="X gpm xft"
+
+RDEPEND=">=sys-libs/slang-2
+ gpm? ( sys-libs/gpm )
+ X? (
+ x11-libs/libX11
+ xft? (
+ >=media-libs/freetype-2
+ x11-libs/libXft
+ )
+ )"
+DEPEND="${RDEPEND}
+ X? (
+ x11-libs/libXt
+ x11-proto/xproto
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ export JED_ROOT="${EPREFIX}"/usr/share/jed
+ econf \
+ $(use_enable gpm) \
+ $(use_enable xft)
+}
+
+src_compile() {
+ emake
+ use X && emake xjed
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+
+ dodoc changes.txt INSTALL{,.unx} README
+ doinfo info/jed*
+
+ insinto /etc
+ doins lib/jed.conf
+
+ # replace IDE mode with EMACS mode
+ sed -i \
+ -e 's/\(_Jed_Default_Emulation = \).*/\1"emacs";/' \
+ "${ED}"/etc/jed.conf || die
+}
diff --git a/app-editors/jed/metadata.xml b/app-editors/jed/metadata.xml
new file mode 100644
index 000000000000..36be58a2be04
--- /dev/null
+++ b/app-editors/jed/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<longdescription>
+ Jed is a powerful editor, terminal and X11 interface. Color syntax
+ highlighting is one of its strong suits, along with emulation of GNU Emacs,
+ Wordstar, EDT and Brief. It also supports use of GPM on Linux consoles.
+ Jed has a multitude of programming modes and couples with the Slang library
+ for powerful extensions.
+</longdescription>
+</pkgmetadata>