summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2017-01-12 08:56:23 +0100
committerMichael Weber <xmw@gentoo.org>2017-01-12 08:56:23 +0100
commitbf461de139b06061347b18342cf98c6c5aeb82e3 (patch)
tree1d4db80f9036cf27fc4595bf0fa4f953893ed73c /app-editors/jupp/jupp-3.1_p30.ebuild
parentapp-editors/jupp: drop old versions. (diff)
downloadgentoo-bf461de139b06061347b18342cf98c6c5aeb82e3.tar.gz
gentoo-bf461de139b06061347b18342cf98c6c5aeb82e3.tar.bz2
gentoo-bf461de139b06061347b18342cf98c6c5aeb82e3.zip
app-editors/jupp: Version bump (thanks mirabilos).
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-editors/jupp/jupp-3.1_p30.ebuild')
-rw-r--r--app-editors/jupp/jupp-3.1_p30.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-editors/jupp/jupp-3.1_p30.ebuild b/app-editors/jupp/jupp-3.1_p30.ebuild
new file mode 100644
index 000000000000..6177bdc524b0
--- /dev/null
+++ b/app-editors/jupp/jupp-3.1_p30.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="portable version of JOE's Own Editor"
+HOMEPAGE="https://www.mirbsd.org/jupp.htm"
+SRC_URI="https://www.mirbsd.org/MirOS/dist/${PN}/joe-${PV/_p/${PN}}.tgz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ncurses"
+
+RDEPEND="ncurses? ( sys-libs/ncurses )
+ !app-editors/joe"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ default
+ chmod +x configure
+}
+
+src_configure() {
+ econf \
+ --enable-search_libs \
+ --enable-termcap \
+ $(use_enable ncurses curses)
+}
+
+src_install() {
+ default
+ dodoc HINTS INFO LIST
+}