summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMykyta Holubakha <hilobakho@gmail.com>2016-11-11 01:55:43 +0200
committerDavid Seifert <soap@gentoo.org>2016-11-12 16:01:54 +0100
commit75357f680cb57e4e31e130e042cfde2d9edbb994 (patch)
treee47783d3d93fc635f06486a7f58168d151d739a7 /app-editors/kakoune/kakoune-0_pre20161111.ebuild
parentsci-physics/rivet: Fixing URL for refs.bib (diff)
downloadgentoo-75357f680cb57e4e31e130e042cfde2d9edbb994.tar.gz
gentoo-75357f680cb57e4e31e130e042cfde2d9edbb994.tar.bz2
gentoo-75357f680cb57e4e31e130e042cfde2d9edbb994.zip
app-editors/kakoune: version bump to 0_pre20161111
introduce static use flag Closes: https://github.com/gentoo/gentoo/pull/2802 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-editors/kakoune/kakoune-0_pre20161111.ebuild')
-rw-r--r--app-editors/kakoune/kakoune-0_pre20161111.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-editors/kakoune/kakoune-0_pre20161111.ebuild b/app-editors/kakoune/kakoune-0_pre20161111.ebuild
new file mode 100644
index 000000000000..1e7e6df595fd
--- /dev/null
+++ b/app-editors/kakoune/kakoune-0_pre20161111.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs vcs-snapshot versionator
+
+REF="85ce5db08a6461f5fef13cc4f6b090c858698d91"
+
+DESCRIPTION="Selection-oriented code editor inspired by vim"
+HOMEPAGE="https://github.com/mawww/kakoune"
+SRC_URI="https://github.com/mawww/${PN}/tarball/${REF} -> ${P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug static"
+
+RDEPEND="
+ sys-libs/ncurses:0=[unicode]
+ dev-libs/boost:=
+"
+DEPEND="
+ app-text/asciidoc
+ virtual/pkgconfig
+ ${RDEPEND}
+"
+
+PATCHES=( "${FILESDIR}/${PN}-0_pre20161111-makefile.patch" )
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if tc-is-gcc && ! version_is_at_least 5.0 $(gcc-version); then
+ die "Clang or GCC >=5.0 is required to build this version"
+ fi
+ fi
+}
+
+src_configure() {
+ append-cppflags $($(tc-getPKG_CONFIG) --cflags ncursesw)
+ append-libs $($(tc-getPKG_CONFIG) --libs ncursesw)
+ tc-export CXX
+ export debug=$(usex debug)
+ export static=$(usex static)
+}
+
+src_install() {
+ emake -C src DESTDIR="${D}" PREFIX="${EPREFIX}/usr" docdir="${ED%/}/usr/share/doc/${PF}" install
+}