summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Hixson <mujo@sdf.org>2021-11-15 12:44:24 -0800
committerJoonas Niilola <juippis@gentoo.org>2021-11-18 13:24:46 +0200
commitbaf53fd17540844ecbf37bd3ad720cc8fc5085fe (patch)
treedc1ab6db390981008893b00e511ddbec0242994e /app-editors/kakoune/kakoune-2021.11.08.ebuild
parentnet-im/telegram-desktop-bin: drop old (diff)
downloadgentoo-baf53fd17540844ecbf37bd3ad720cc8fc5085fe.tar.gz
gentoo-baf53fd17540844ecbf37bd3ad720cc8fc5085fe.tar.bz2
gentoo-baf53fd17540844ecbf37bd3ad720cc8fc5085fe.zip
app-editors/kakoune: bump to 2021.11.08
Signed-off-by: Ian Hixson <mujo@sdf.org> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-editors/kakoune/kakoune-2021.11.08.ebuild')
-rw-r--r--app-editors/kakoune/kakoune-2021.11.08.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-editors/kakoune/kakoune-2021.11.08.ebuild b/app-editors/kakoune/kakoune-2021.11.08.ebuild
new file mode 100644
index 000000000000..67d9bb162963
--- /dev/null
+++ b/app-editors/kakoune/kakoune-2021.11.08.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Modal editor inspired by vim"
+HOMEPAGE="http://kakoune.org/ https://github.com/mawww/kakoune"
+SRC_URI="https://github.com/mawww/kakoune/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ sed -i '/CXXFLAGS += -O3/d' src/Makefile || die
+ default
+}
+
+src_configure() {
+ tc-export CXX
+}
+
+src_compile() {
+ emake -C src all
+}
+
+src_test() {
+ emake -C src test
+}
+
+src_install() {
+ emake PREFIX="${D}"/usr docdir="${ED}/usr/share/doc/${PF}" install
+
+ rm "${ED}/usr/share/man/man1/kak.1.gz" || die
+ doman doc/kak.1
+}