summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-07-27 22:59:22 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-07-28 03:27:28 +0200
commit9d240c8603952a3b9b54aca6a56397e9f19f29f6 (patch)
tree948e236c8b28c7e3af847ad911a0d6694e844a81 /app-editors/kile
parentsys-block/kvpm: Drop 0.9.10 (diff)
downloadgentoo-9d240c8603952a3b9b54aca6a56397e9f19f29f6.tar.gz
gentoo-9d240c8603952a3b9b54aca6a56397e9f19f29f6.tar.bz2
gentoo-9d240c8603952a3b9b54aca6a56397e9f19f29f6.zip
app-editors/kile: kile-2.9.92_p20190716 snapshot bump, EAPI-7
Contains fetched translations and handbook using upstream's tarme.rb Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-editors/kile')
-rw-r--r--app-editors/kile/Manifest1
-rw-r--r--app-editors/kile/kile-2.9.92_p20190716.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/app-editors/kile/Manifest b/app-editors/kile/Manifest
index 3452504f8d52..43d82c3058b4 100644
--- a/app-editors/kile/Manifest
+++ b/app-editors/kile/Manifest
@@ -1 +1,2 @@
DIST kile-2.9.92.tar.bz2 8556142 BLAKE2B dd18ece7394439de3c0037fbea7c66316c5ee457bd4ad8c35f8519713f917e1c1641c806290303c26dd9e31e2f39346bc35091b211ca23a2d342332388d18c3f SHA512 e3af0c2cb1a0970428e2d772ef5025ead67aee94cdc03b6ec173de5628e8d4619f74296a1734eac8241939d40a05b805b8bd33bb4c27a1c19ad47fb35087cf7d
+DIST kile-2.9.92_p20190716.tar.xz 6176728 BLAKE2B cc6b5f12c7798c806a1e78b79c32e90a3f713d65429afbddfbf75a3a666cfbea75d32be1c2e7d15ce2e414301473f03168e84428bcec161cfd12ceeba674add3 SHA512 614d6aba168f47af41e6a352e7ad838c187945b857c19654ce40ea80c359e5d88a184f1ab02b404c022b897f8ac6f3a61323c9d1043fbb0412eb3d16690e40bb
diff --git a/app-editors/kile/kile-2.9.92_p20190716.ebuild b/app-editors/kile/kile-2.9.92_p20190716.ebuild
new file mode 100644
index 000000000000..abd1a6c09764
--- /dev/null
+++ b/app-editors/kile/kile-2.9.92_p20190716.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Latex Editor and TeX shell based on KDE Frameworks"
+HOMEPAGE="https://kile.sourceforge.io/"
+SRC_URI="https://dev.gentoo.org/~asturm/distfiles/${P}.tar.xz"
+
+LICENSE="FDL-1.2 GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+pdf +png"
+
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdoctools)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep khtml)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep ktexteditor)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep okular)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtscript)
+ $(add_qt_dep qttest)
+ $(add_qt_dep qtwidgets)
+ pdf? ( app-text/poppler[qt5] )
+"
+RDEPEND="${DEPEND}
+ !app-editors/kile:4
+ $(add_kdeapps_dep konsole)
+ $(add_kdeapps_dep okular 'pdf?')
+ virtual/latex-base
+ virtual/tex-base
+ pdf? (
+ >=app-text/texlive-core-2014
+ app-text/ghostscript-gpl
+ )
+ png? (
+ app-text/dvipng
+ virtual/imagemagick-tools[png?]
+ )
+"
+
+DOCS=( kile-remote-control.txt )
+
+src_prepare() {
+ kde5_src_prepare
+
+ # I know upstream wants to help us but it doesn't work..
+ sed -e '/INSTALL( FILES AUTHORS/s/^/#DISABLED /' \
+ -i CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package pdf Poppler)
+ )
+
+ kde5_src_configure
+}