summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2017-08-15 17:08:47 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2017-08-16 00:59:52 +0200
commitc548f829f3c9b2510ef9f3107ac19981c9851f2d (patch)
tree837b5b1099198bba20fc5b60abab2719133fb6e9 /app-editors/latexila/latexila-3.24.2.ebuild
parentx11-libs/gtef: initial ebuild (diff)
downloadgentoo-c548f829f3c9b2510ef9f3107ac19981c9851f2d.tar.gz
gentoo-c548f829f3c9b2510ef9f3107ac19981c9851f2d.tar.bz2
gentoo-c548f829f3c9b2510ef9f3107ac19981c9851f2d.zip
app-editors/latexila: version bump 3.22.1 → 3.24.2
Package-Manager: Portage-2.3.7, Repoman-2.3.3 RepoMan-Options: --force
Diffstat (limited to 'app-editors/latexila/latexila-3.24.2.ebuild')
-rw-r--r--app-editors/latexila/latexila-3.24.2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/app-editors/latexila/latexila-3.24.2.ebuild b/app-editors/latexila/latexila-3.24.2.ebuild
new file mode 100644
index 000000000000..d95cfae59a3f
--- /dev/null
+++ b/app-editors/latexila/latexila-3.24.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+VALA_MIN_API_VERSION="0.34"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala
+
+DESCRIPTION="Integrated LaTeX environment for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/LaTeXila"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection +latexmk rubber"
+
+COMMON_DEPEND="
+ $(vala_depend)
+ app-text/enchant
+ >=app-text/gspell-1.0:0=
+ >=dev-libs/glib-2.50:2[dbus]
+ >=dev-libs/libgee-0.10:0.8=
+ gnome-base/gsettings-desktop-schemas
+ >=x11-libs/gtef-2.0
+ >=x11-libs/gtk+-3.20:3
+ >=x11-libs/gtksourceview-3.24:3.0=
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+ introspection? ( >=dev-libs/gobject-introspection-1.30.0:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ virtual/latex-base
+ x11-themes/hicolor-icon-theme
+ latexmk? ( dev-tex/latexmk )
+ rubber? ( dev-tex/rubber )
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ dev-util/gdbus-codegen
+ >=dev-util/gtk-doc-am-1.14
+ >=dev-util/intltool-0.50.1
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ gnome2_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection)
+}