summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2022-11-12 12:08:47 +0100
committerUlrich Müller <ulm@gentoo.org>2022-11-12 12:10:50 +0100
commit0c533a66852c05a4d2ce95c876e6469a6672a617 (patch)
tree7a35e84a4f813dbf4b64d73096f7c2169afe7991 /app-editors/mg
parentsci-geosciences/gpxsee: Stabilize 11.5 amd64, #881047 (diff)
downloadgentoo-0c533a66852c05a4d2ce95c876e6469a6672a617.tar.gz
gentoo-0c533a66852c05a4d2ce95c876e6469a6672a617.tar.bz2
gentoo-0c533a66852c05a4d2ce95c876e6469a6672a617.zip
app-editors/mg: add 20221112
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-editors/mg')
-rw-r--r--app-editors/mg/Manifest1
-rw-r--r--app-editors/mg/mg-20221112.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-editors/mg/Manifest b/app-editors/mg/Manifest
index 38f60b892831..b65213652e67 100644
--- a/app-editors/mg/Manifest
+++ b/app-editors/mg/Manifest
@@ -1,2 +1,3 @@
DIST mg-20220212.tar.gz 157828 BLAKE2B e3219efffef9c4da05965a0ed7a0f0bfdf5c34d607d25102a4d2ee9de6f9b9fd2da59050c6e56d1712875b2d129408200dde4c7305ffb2208c11b5d722b87270 SHA512 093736521e4bcaeff049594793474b9710e4cfe6db151032dc4413614566afce80db5b794dcf10082020dbb73f25742a0c7d49f45b6b4d2caa6865b20a9e574b
DIST mg-20220614.tar.gz 157904 BLAKE2B 88141274b379c6117158f85d91d0d643709437f0292fe2f82569c33d85694b39f957e279e262839ef0ba2a7e81e8a9ad6512c621e68f42b0929805028898637a SHA512 bed455cda856e54fae28592ac0a520841d5d542880a7405dadf702d7407ac33ae7fb7b63880805a7e166e0e0a87c76b9fca1700c444f1b999a5af66732c69b65
+DIST mg-20221112.tar.gz 158666 BLAKE2B b32f957a4491901c0926668fb74df450de679d95d1ca2352f7eab0be0e6fa06b703551c3f9be6bed80918daec9096fbbc8f774f3e0255c668a8ebe0c0bcf99a6 SHA512 7d2d08d7015357ceece4eeaf876a3c0a8e27554aed224854efb831c23c78157a104df724b9ac3ad9f74efce6b066c94616fadf8979906f453469a03bc5d005b8
diff --git a/app-editors/mg/mg-20221112.ebuild b/app-editors/mg/mg-20221112.ebuild
new file mode 100644
index 000000000000..7d529ea79741
--- /dev/null
+++ b/app-editors/mg/mg-20221112.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="MicroGnuEmacs, a port from the BSDs"
+HOMEPAGE="https://github.com/hboetes/mg"
+SRC_URI="https://github.com/hboetes/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="livecd"
+
+RDEPEND="
+ sys-libs/ncurses:0=
+ >=dev-libs/libbsd-0.7.0"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ # fix path to tutorial in man page
+ sed -i -e "s:doc/mg/:doc/${PF}/:" mg.1 || die
+ eapply_user
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ dobin mg
+ doman mg.1
+ dodoc README tutorial
+ # don't compress the tutorial, otherwise mg cannot open it
+ docompress -x /usr/share/doc/${PF}/tutorial
+}
+
+pkg_postinst() {
+ if use livecd; then
+ [[ -e ${EROOT}/usr/bin/emacs ]] || ln -s mg "${EROOT}"/usr/bin/emacs
+ fi
+}