summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-04-27 16:40:41 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-04-27 16:40:41 +0200
commitbe8044b7a0bce096b5cb8d459922bad0b317eb33 (patch)
treefc86f84954e2bae5a7f2f95e6af13b5650462fe3 /app-editors/nano
parentapache-2.eclass: Minor adjustments. (diff)
downloadgentoo-be8044b7a0bce096b5cb8d459922bad0b317eb33.tar.gz
gentoo-be8044b7a0bce096b5cb8d459922bad0b317eb33.tar.bz2
gentoo-be8044b7a0bce096b5cb8d459922bad0b317eb33.zip
app-editors/nano: Bump to version 2.9.6
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'app-editors/nano')
-rw-r--r--app-editors/nano/Manifest1
-rw-r--r--app-editors/nano/nano-2.9.6.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/app-editors/nano/Manifest b/app-editors/nano/Manifest
index 3555fbd43889..e139dd3b7d39 100644
--- a/app-editors/nano/Manifest
+++ b/app-editors/nano/Manifest
@@ -1,3 +1,4 @@
DIST nano-2.8.7.tar.gz 2822417 BLAKE2B 2559497b9aee4d4c3cfc86e8af6a54bc0af58588c7bd1142a0e97c6ce50aed66c3852745b83a457263659e97592f0775dcc94c44d818e20440b6524202bfe49a SHA512 511b57f8fe82872827829bca91f7a8666a6ee75924cf2c853332ddd0467abf281c6d3cbaa5dd208c579cbace5bef23d36bd7b62be116aa2175262ed1d15aaf79
DIST nano-2.9.4.tar.gz 2874037 BLAKE2B 493005cd3635fa7ad9508d6a24076e3a23b9038e5e4fbecf2a9ea51e03c861eaaf0fbe3e566075394523669350b1e396140f0bc6504953bb7c99690d47ef502f SHA512 dec4259668716a49d6dc403aabf4e2c0c0148247f9161e6a88c29c573026fcec00a15147b2e6d2c8c1d52fac227ab4d7b3f3552389af97b485da0b875976f0fd
DIST nano-2.9.5.tar.gz 2889382 BLAKE2B fa9a020b133f0b1c669689e0831d2700d7509a01e7355ab7ee613a38b1c6c65e35e9572ad5c4ea4aae427c52ba841d7b5da826bb0afddf25f3d8add8ffa15302 SHA512 623a1d142f5aff62186314d84ea8461e10ab7eb2e11c8a57497736bc5ad432e39d48086d17eb80bdbf9b33adc41e9d77db5416281138993dbea795afd96dbfc0
+DIST nano-2.9.6.tar.gz 2892819 BLAKE2B 572fcd30b3640e1819d2d573c6aa755141b3990ab05fdf4928a8ade4dedd77ee4d8b81644a75d2c698fbc5512b1bffb7e7d449beac57700a77a1f7687ece4d58 SHA512 360802c3d772e8159e729803d5307575b348f779623e49401752984201b6b874df1582fe79ed6552a524db64ae6d8a1bfb449b525f7354cbd5cd9941432a2dff
diff --git a/app-editors/nano/nano-2.9.6.ebuild b/app-editors/nano/nano-2.9.6.ebuild
new file mode 100644
index 000000000000..2b29359919a7
--- /dev/null
+++ b/app-editors/nano/nano-2.9.6.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit eutils flag-o-matic
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.sv.gnu.org/nano.git"
+ inherit git-r3 autotools
+else
+ MY_P="${PN}-${PV/_}"
+ SRC_URI="https://www.nano-editor.org/dist/v${PV:0:3}/${MY_P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="GNU GPL'd Pico clone with more functionality"
+HOMEPAGE="https://www.nano-editor.org/ https://wiki.gentoo.org/wiki/Nano/Basics_Guide"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="debug justify +magic minimal ncurses nls slang +spell static unicode"
+
+LIB_DEPEND=">=sys-libs/ncurses-5.9-r1:0=[unicode?]
+ sys-libs/ncurses:0=[static-libs(+)]
+ magic? ( sys-apps/file[static-libs(+)] )
+ nls? ( virtual/libintl )
+ !ncurses? ( slang? ( sys-libs/slang[static-libs(+)] ) )"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig
+ static? ( ${LIB_DEPEND} )"
+
+src_prepare() {
+ default
+ if [[ ${PV} == "9999" ]] ; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ use static && append-ldflags -static
+ local myconf=(
+ --bindir="${EPREFIX}"/bin
+ --htmldir=/trash
+ $(use_enable !minimal color)
+ $(use_enable !minimal multibuffer)
+ $(use_enable !minimal nanorc)
+ --disable-wrapping-as-root
+ $(use_enable magic libmagic)
+ $(use_enable spell speller)
+ $(use_enable justify)
+ $(use_enable debug)
+ $(use_enable nls)
+ $(use_enable unicode utf8)
+ $(use_enable minimal tiny)
+ $(usex ncurses --without-slang $(use_with slang))
+ )
+ case ${CHOST} in
+ *-gnu*|*-uclibc*) myconf+=( "--with-wordbounds" ) ;; #467848
+ esac
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ rm -rf "${ED%/}"/trash
+
+ dodoc doc/sample.nanorc
+ docinto html
+ dodoc doc/faq.html
+ insinto /etc
+ newins doc/sample.nanorc nanorc
+ if ! use minimal ; then
+ # Enable colorization by default.
+ sed -i \
+ -e '/^# include /s:# *::' \
+ "${ED%/}"/etc/nanorc || die
+ fi
+
+ dosym ../../bin/nano /usr/bin/nano
+}