summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAric Belsito <lluixhi@gmail.com>2017-10-31 12:36:22 -0700
committerPatrice Clement <monsieurp@gentoo.org>2018-01-05 18:43:40 +0100
commit7ec4b117cc739c03067cfab7607c73af2c52feca (patch)
tree2dc60c1b83c593bffb800058df1782965c6fe027 /app-editors/neovim/neovim-9999.ebuild
parentdev-python/neovim-remote: new package. (diff)
downloadgentoo-7ec4b117cc739c03067cfab7607c73af2c52feca.tar.gz
gentoo-7ec4b117cc739c03067cfab7607c73af2c52feca.tar.bz2
gentoo-7ec4b117cc739c03067cfab7607c73af2c52feca.zip
app-editors/neovim: add remote USE flag.
Diffstat (limited to 'app-editors/neovim/neovim-9999.ebuild')
-rw-r--r--app-editors/neovim/neovim-9999.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/app-editors/neovim/neovim-9999.ebuild b/app-editors/neovim/neovim-9999.ebuild
index a37942870e06..9694b6c32c21 100644
--- a/app-editors/neovim/neovim-9999.ebuild
+++ b/app-editors/neovim/neovim-9999.ebuild
@@ -11,12 +11,12 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/neovim/neovim.git"
else
SRC_URI="https://github.com/neovim/neovim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
+ KEYWORDS="~amd64 ~x86"
fi
LICENSE="Apache-2.0 vim"
SLOT="0"
-IUSE="+clipboard +luajit +nvimpager python ruby +tui +jemalloc"
+IUSE="+clipboard +luajit +nvimpager python remote ruby +tui +jemalloc"
CDEPEND=">=dev-libs/libuv-1.2.0
>=dev-libs/msgpack-1.0.0
@@ -44,6 +44,7 @@ RDEPEND="
${CDEPEND}
python? ( dev-python/neovim-python-client )
ruby? ( dev-ruby/neovim-ruby-client )
+ remote? ( dev-python/neovim-remote )
clipboard? ( || ( x11-misc/xsel x11-misc/xclip ) )"
CMAKE_BUILD_TYPE=RelWithDebInfo