summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-07-02 14:02:28 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-07-02 14:21:51 +0200
commit9785bcf11ba35530da53ab95bbf0d5309bdb6041 (patch)
treeb3ae0056467038376e8b6def6c1dbeb900d6bd3d /app-editors/okteta
parentapp-admin/haskell-updater: x86 stable wrt bug #689138 (diff)
downloadgentoo-9785bcf11ba35530da53ab95bbf0d5309bdb6041.tar.gz
gentoo-9785bcf11ba35530da53ab95bbf0d5309bdb6041.tar.bz2
gentoo-9785bcf11ba35530da53ab95bbf0d5309bdb6041.zip
app-editors/okteta: 0.26.2 version bump
Package-Manager: Portage-2.3.68, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-editors/okteta')
-rw-r--r--app-editors/okteta/Manifest1
-rw-r--r--app-editors/okteta/okteta-0.26.2.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/app-editors/okteta/Manifest b/app-editors/okteta/Manifest
index 1571166e91ff..67748879f582 100644
--- a/app-editors/okteta/Manifest
+++ b/app-editors/okteta/Manifest
@@ -1 +1,2 @@
DIST okteta-0.26.1.tar.xz 970532 BLAKE2B c04e0c4a2665f91cde26ee28b95f768f3074a08c8fd30920c75f3ce52fdfa717e3e6cea9acf87c3c5d53c830e5badb51faa2abcebd5b55839ea4ee52874a6d4c SHA512 fa4e841c77ae255e9936b29e30fa0bc1f65594898820652ac8ba78497658ec5ef78cadf8b4d33cab09b2ee8da1d75b84377be28680b2d91c5af2dcdfe5da95e3
+DIST okteta-0.26.2.tar.xz 976264 BLAKE2B 6bd0708ecab61097130ad3b96d44c4a58a7711f6d9ecc9c70d3db792728489f395e691b0157f0cf8ffc0e07b1796ce6fde9f689108c3236412ad37c4e87a210a SHA512 9d79cfecf80a7bfd4eb42ac8ee93d83140064601c16be0bed38481f7f0ea8ed2fa0aedfd16be3547f2bbd65ab483281e0ecdc0e59799040d67ecf1b4cda39246
diff --git a/app-editors/okteta/okteta-0.26.2.ebuild b/app-editors/okteta/okteta-0.26.2.ebuild
new file mode 100644
index 000000000000..614b30f95d11
--- /dev/null
+++ b/app-editors/okteta/okteta-0.26.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Hex editor by KDE"
+HOMEPAGE="https://kde.org/applications/utilities/okteta
+https://utils.kde.org/projects/okteta/"
+IUSE="crypt designer"
+
+DEPEND="
+ $(add_frameworks_dep kbookmarks)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtscript 'scripttools')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ crypt? ( app-crypt/qca:2[qt5(+)] )
+ designer? ( $(add_qt_dep designer) )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DOMIT_EXAMPLES=ON
+ $(cmake-utils_use_find_package crypt Qca-qt5)
+ -DBUILD_DESIGNERPLUGIN=$(usex designer)
+ )
+
+ kde5_src_configure
+}
+
+src_test() {
+ local myctestargs=( -j1 )
+
+ kde5_src_test
+}