summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-10-29 00:42:10 +1100
committerMichael Palimaka <kensington@gentoo.org>2016-10-29 00:42:34 +1100
commit3fa80722e2defd5f52bdd7e1759c9b35a60472cc (patch)
treeaa42035dba99c7c0eee9cf379fe627f0b6df2e20 /app-editors/tea/tea-43.1.0.ebuild
parentapp-editors/focuswriter: version bump (diff)
downloadgentoo-3fa80722e2defd5f52bdd7e1759c9b35a60472cc.tar.gz
gentoo-3fa80722e2defd5f52bdd7e1759c9b35a60472cc.tar.bz2
gentoo-3fa80722e2defd5f52bdd7e1759c9b35a60472cc.zip
app-editors/tea: version bump
Package-Manager: portage-2.3.2
Diffstat (limited to 'app-editors/tea/tea-43.1.0.ebuild')
-rw-r--r--app-editors/tea/tea-43.1.0.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/app-editors/tea/tea-43.1.0.ebuild b/app-editors/tea/tea-43.1.0.ebuild
new file mode 100644
index 000000000000..e9344b248977
--- /dev/null
+++ b/app-editors/tea/tea-43.1.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils qmake-utils
+
+DESCRIPTION="Small, lightweight Qt text editor"
+HOMEPAGE="http://tea.ourproject.org/"
+SRC_URI="http://tea.ourproject.org/dloads/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="aspell djvu hunspell pdf"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+ sys-libs/zlib
+ aspell? ( app-text/aspell )
+ djvu? ( app-text/djvu )
+ hunspell? ( app-text/hunspell:= )
+ pdf? ( app-text/poppler[qt5] )
+"
+DEPEND="${RDEPEND}
+ hunspell? ( virtual/pkgconfig )
+"
+
+DOCS=( AUTHORS ChangeLog NEWS NEWS-RU TODO )
+
+src_configure() {
+ eqmake5 src.pro \
+ $(use aspell || echo CONFIG+=noaspell) \
+ $(use djvu && echo CONFIG+=usedjvu) \
+ $(use hunspell || echo CONFIG+=nohunspell) \
+ $(use pdf && echo CONFIG+=usepoppler)
+}
+
+src_install() {
+ dobin bin/tea
+
+ einstalldocs
+ docinto html
+ dodoc manuals/*.html
+
+ insinto /usr/share/qt5/translations
+ doins translations/${PN}_*.qm
+
+ newicon icons/tea-icon-v3-01.png ${PN}.png
+ make_desktop_entry ${PN} 'Tea Editor'
+}