summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-08-16 01:25:50 +0200
committerUlrich Müller <ulm@gentoo.org>2019-08-16 09:10:09 +0200
commit12d86417f30b2923c074ae0436eddadbbc85a105 (patch)
tree0ad4602290d3a39950b2bb379bea75a6e9a81866 /app-editors/teco/teco-36_p19940820.ebuild
parentapp-editors/teco: Add slot operator for ncurses. (diff)
downloadgentoo-12d86417f30b2923c074ae0436eddadbbc85a105.tar.gz
gentoo-12d86417f30b2923c074ae0436eddadbbc85a105.tar.bz2
gentoo-12d86417f30b2923c074ae0436eddadbbc85a105.zip
app-editors/teco: Move to more accurate version 36_p19940820.
This is not actually a version bump. te_defs.h defines VERSION as 36. teco.tar.gz has a timestamp 1994-08-20 14:23:53 UTC, which agrees with the latest file modification date in the tarball. Bump EAPI to 7, and make patches work with eapply (i.e., patch -p1). Documentation is now in a single tarball. Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-editors/teco/teco-36_p19940820.ebuild')
-rw-r--r--app-editors/teco/teco-36_p19940820.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/app-editors/teco/teco-36_p19940820.ebuild b/app-editors/teco/teco-36_p19940820.ebuild
new file mode 100644
index 000000000000..dc730a589794
--- /dev/null
+++ b/app-editors/teco/teco-36_p19940820.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs flag-o-matic readme.gentoo-r1
+
+DESCRIPTION="Classic TECO editor, Predecessor to EMACS"
+HOMEPAGE="http://www.ibiblio.org/pub/linux/apps/editors/tty/ http://www.ibiblio.org/pub/academic/computer-science/history/pdp-11/teco"
+SRC_URI="http://www.ibiblio.org/pub/linux/apps/editors/tty/teco.tar.gz -> ${P}.tar.gz
+ doc? ( https://dev.gentoo.org/~ulm/distfiles/tecodoc.tar.gz )"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE="doc"
+
+RDEPEND="sys-libs/ncurses:0="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-double-free.diff
+ "${FILESDIR}"/${PN}-gcc4.patch
+ "${FILESDIR}"/${PN}-warnings.patch
+)
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ use doc && unpack tecodoc.tar.gz
+}
+
+src_prepare() {
+ default
+ local pkg_config=$("$(tc-getPKG_CONFIG)" --libs ncurses)
+ sed -i -e "s:\$(CC):& \$(LDFLAGS):;s:-ltermcap:${pkg_config}:" \
+ Makefile || die
+}
+
+src_compile() {
+ append-flags -ansi
+ append-cppflags -D_POSIX_SOURCE
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin te
+ doman te.1
+ dodoc sample.tecorc sample.tecorc2 READ.ME
+ use doc && dodoc doc/*
+
+ DOC_CONTENTS="The TECO binary is called te.
+ \nSample configurations and documentation are available
+ in /usr/share/doc/${PF}/."
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}