summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-07-07 13:09:34 -0700
committerMatt Turner <mattst88@gentoo.org>2022-07-07 13:11:10 -0700
commit5bb0d5499f28589cbac80de023b7087da7c69780 (patch)
tree89264b4fcd280c08e7395a39c4cbb76f296e450c /app-editors/vim
parentapp-editors/vim-core: Sync live ebuild (diff)
downloadgentoo-5bb0d5499f28589cbac80de023b7087da7c69780.tar.gz
gentoo-5bb0d5499f28589cbac80de023b7087da7c69780.tar.bz2
gentoo-5bb0d5499f28589cbac80de023b7087da7c69780.zip
app-editors/vim: Sync live ebuild
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-editors/vim')
-rw-r--r--app-editors/vim/vim-8.2.5066-r1.ebuild2
-rw-r--r--app-editors/vim/vim-9999.ebuild6
2 files changed, 3 insertions, 5 deletions
diff --git a/app-editors/vim/vim-8.2.5066-r1.ebuild b/app-editors/vim/vim-8.2.5066-r1.ebuild
index f66b1592e72b..bcec32097911 100644
--- a/app-editors/vim/vim-8.2.5066-r1.ebuild
+++ b/app-editors/vim/vim-8.2.5066-r1.ebuild
@@ -118,7 +118,7 @@ src_prepare() {
# which isn't even in the source file being invalid, we'll do some trickery
# to make the error never occur. bug 66162 (02 October 2004 ciaranm)
find "${S}" -name '*.c' | while read c; do
- echo >> "$c" || die "echo failed"
+ echo >> "$c" || die "echo failed"
done
# conditionally make the manpager.sh script
diff --git a/app-editors/vim/vim-9999.ebuild b/app-editors/vim/vim-9999.ebuild
index 0afdaaef7172..bcec32097911 100644
--- a/app-editors/vim/vim-9999.ebuild
+++ b/app-editors/vim/vim-9999.ebuild
@@ -18,7 +18,7 @@ if [[ ${PV} == 9999* ]] ; then
EGIT_REPO_URI="https://github.com/vim/vim.git"
else
SRC_URI="https://github.com/vim/vim/archive/v${PV}.tar.gz -> ${P}.tar.gz
- https://dev.gentoo.org/~zlogene/distfiles/app-editors/vim/vim-8.2.0360-gentoo-patches.tar.xz"
+ https://dev.gentoo.org/~mattst88/distfiles/vim-8.2.5066-gentoo-patches.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
@@ -80,8 +80,6 @@ pkg_setup() {
src_prepare() {
if [[ ${PV} != 9999* ]] ; then
- rm "${WORKDIR}"/patches/006-vim-8.0.0617-crosscompile.patch || die
-
# Gentoo patches to fix runtime issues, cross-compile errors, etc
eapply "${WORKDIR}"/patches/
fi
@@ -120,7 +118,7 @@ src_prepare() {
# which isn't even in the source file being invalid, we'll do some trickery
# to make the error never occur. bug 66162 (02 October 2004 ciaranm)
find "${S}" -name '*.c' | while read c; do
- echo >> "$c" || die "echo failed"
+ echo >> "$c" || die "echo failed"
done
# conditionally make the manpager.sh script