summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <rhill@gentoo.org>2015-12-14 17:35:33 -0600
committerRyan Hill <rhill@gentoo.org>2015-12-14 17:35:33 -0600
commit36f20e902afe189529639ba25fe6ccaccf31c6da (patch)
treec7134498700c990c83642a47e8164b47676705dc /app-editors/wxhexeditor
parentkde-apps/kapptemplate: Work with Frameworks 5.17.0 (diff)
downloadgentoo-36f20e902afe189529639ba25fe6ccaccf31c6da.tar.gz
gentoo-36f20e902afe189529639ba25fe6ccaccf31c6da.tar.bz2
gentoo-36f20e902afe189529639ba25fe6ccaccf31c6da.zip
app-editors/wxhexeditor: Version bump, bug #542790.
Package-Manager: portage-2.2.26 Signed-off-by: Ryan Hill <rhill@gentoo.org>
Diffstat (limited to 'app-editors/wxhexeditor')
-rw-r--r--app-editors/wxhexeditor/Manifest1
-rw-r--r--app-editors/wxhexeditor/files/wxhexeditor-0.23-syslibs.patch84
-rw-r--r--app-editors/wxhexeditor/wxhexeditor-0.23.ebuild46
3 files changed, 131 insertions, 0 deletions
diff --git a/app-editors/wxhexeditor/Manifest b/app-editors/wxhexeditor/Manifest
index bdecce43fb00..a757244b5bbc 100644
--- a/app-editors/wxhexeditor/Manifest
+++ b/app-editors/wxhexeditor/Manifest
@@ -1,3 +1,4 @@
DIST wxHexEditor-v0.20-src.tar.bz2 1194554 SHA256 a3dda32eb62e3ec1c9760519302bcef688253d48b3d2c566f9629c4e4246ae55 SHA512 f8138fb892528fd7d131b0931f52cb6b19dc984aa831882d7f60f557527e6bb559429a11b5a1307cf51d1a8974123627d15ccee87561970784a75910929f85a3 WHIRLPOOL 9d3343060f815fae7b2512b098c3a1c4853c062040cb2b180bf7402231295d27e96a3996aca041ce2f694f2cc84bb6dfbc419797079713afb254900187d100e0
DIST wxHexEditor-v0.21-src.tar.bz2 1760192 SHA256 076111ebcf1472e80ec9a16223ca60bdf4598689cc5aa076a4f9760bba51f17f SHA512 bea80a139bb76e47ed5d3644f923b4b042d8842bb3522e88e2c84947eadc7f49f2599438f583ea8a1fde05356886d8fb20f679398e1519c13acd8e4dd49ad729 WHIRLPOOL fd5ebc1609183b8879254461c7eb1a22355a2f71ca45452a6dd21ca8164c5b8b96474d9d1c01b2aea962d4d47c291e3b43d8bf1d337c7bcff6c1c109c3fe29b9
DIST wxHexEditor-v0.22-src.tar.bz2 2329754 SHA256 3c04725d218d21807ee78ccdd4bc78d302b92139c92bbd0a0edc53f2d0003996 SHA512 d846b30110bf2c864ec8dc45d1a4e9e333ec79379e335d7ecf5c8eed18a22bf2af26de1bcdca1977c94f2789a82c6eaf5fd2c2a91389f4c20f219a974c5e18ac WHIRLPOOL 44988f4349bc78ce7dd975ce7332a72dc5176e3308a9837e0634cce55e029a758488ed1ff07fdcd1f8c64638b0bf86ea8b73cc4c8f7b7400384487eb6bbfea1d
+DIST wxHexEditor-v0.23-src.tar.bz2 2534659 SHA256 24a5a8b8df3abfbc3836d07b379003b45ea0ab0d2d45cb9611c797c595f8972b SHA512 abbd2338c2d0d7d514342f5c330ea42c9ee1f3489c4661426927f51c802a7806e4ee965fa5d467c7b928ba87395eb6c351ab5f43f18d5fce836adede5f1d6be4 WHIRLPOOL 808bc8694a89f1eadb1b2c772cd69c76c7e3aba82d793f94f75a6392de5009546c2ada78bd8513f551edfd878251056ace367d9bbfdb21cd5f0bea4899c30c9f
diff --git a/app-editors/wxhexeditor/files/wxhexeditor-0.23-syslibs.patch b/app-editors/wxhexeditor/files/wxhexeditor-0.23-syslibs.patch
new file mode 100644
index 000000000000..341c63bd8dd5
--- /dev/null
+++ b/app-editors/wxhexeditor/files/wxhexeditor-0.23-syslibs.patch
@@ -0,0 +1,84 @@
+Use system copies of mhash and udis86.
+Also pass -fopenmp when linking to avoid build errors.
+
+--- a/Makefile
++++ b/Makefile
+@@ -3,9 +3,9 @@ WXCONFIG = wx-config
+ #CXX ?= `$(WXCONFIG) --cxx`
+ CC = `$(WXCONFIG) --cc`
+ CXX = `$(WXCONFIG) --cxx`
+-LDFLAGS += -lgomp
++LDFLAGS += -fopenmp -lgomp
+ #add this ldflags for WinConsole "-Wl,--subsystem,console -mconsole" for win-debug
+-WXCXXFLAGS= `$(WXCONFIG) --cxxflags` -Iudis86 -Imhash/include -MMD -fopenmp
++WXCXXFLAGS= `$(WXCONFIG) --cxxflags` -MMD -fopenmp
+ WXLDFLAGS = `$(WXCONFIG) --libs` `$(WXCONFIG) --libs aui` `$(WXCONFIG) --libs core`
+ RC = `$(WXCONFIG) --rescomp`
+ #RC = x86_64-w64-mingw32-windres --define WX_CPU_AMD64
+@@ -25,7 +25,7 @@ SOURCES= src/HexEditorGui.cpp \
+ src/HexEditorCtrl/wxHexCtrl/Tag.cpp\
+ src/HexEditorCtrl/HexEditorCtrlGui.cpp\
+ src/HexEditorFrame.cpp
+-LIBS = udis86/libudis86/.libs/libudis86.a mhash/lib/.libs/libmhash.a
++LIBS = -ludis86 -lmhash
+ OBJECTS=$(SOURCES:.cpp=.o)
+ DEPENDS=$(OBJECTS:.o=.d)
+ LANGUAGEDIRS=`ls -l ./locale | grep ^d | sed s/.*\ //g;`
+@@ -36,7 +36,7 @@ EXECUTABLE=wxHexEditor
+ EXECUTABLE_WIN=$(EXECUTABLE).exe
+ EXECUTABLE_DIR_MAC=$(EXECUTABLE).app
+
+-PREFIX = /usr/local
++PREFIX = /usr
+ BINDIR = $(PREFIX)/bin
+ DATADIR = $(PREFIX)/share
+ LOCALEDIR = $(DATADIR)/locale
+@@ -63,15 +63,6 @@ langs: $(MOBJECTS)
+ %.mo : %.po
+ $(MSGFMT) $< -o $@
+
+-udis86/libudis86/.libs/libudis86.a:
+- cd udis86;./autogen.sh
+- cd udis86;./configure --host=$(HOST) CFLAGS="$(CFLAGS)" CXXFLAGS="$(CXXFLAGS)" CPPFLAGS="$(CPPFLAGS)"
+- cd udis86/libudis86; $(MAKE) $(MFLAGS)
+-
+-mhash/lib/.libs/libmhash.a:
+- cd mhash; ./configure --host=$(HOST) CFLAGS="$(CFLAGS)" CXXFLAGS="$(CXXFLAGS)" CPPFLAGS="$(CPPFLAGS)"
+- cd mhash; $(MAKE) $(MFLAGS)
+-
+ win: $(RESOURCES) $(EXECUTABLE_WIN)
+
+ #Stack override required for file comparison function...
+--- a/src/HexDialogs.cpp
++++ b/src/HexDialogs.cpp
+@@ -24,7 +24,7 @@
+ #define NANINT 0xFFFFFFFFFFFFFFFFLL
+ #include "HexDialogs.h"
+ #include <wx/progdlg.h>
+-#include "../mhash/include/mhash.h"
++#include <mhash.h>
+
+ #ifdef _OPENMP_
+ #include <omp.h>
+--- a/src/HexEditor.h
++++ b/src/HexEditor.h
+@@ -25,7 +25,7 @@
+ #ifndef _wxHexEditor_h_
+ #define _wxHexEditor_h_
+
+-#include "../mhash/include/mhash.h"
++#include <mhash.h>
+
+ #include <wx/ffile.h>
+ #include <wx/clipbrd.h>
+--- a/src/HexPanels.h
++++ b/src/HexPanels.h
+@@ -27,7 +27,7 @@
+ #include "HexEditorFrame.h"
+ #include "HexEditorCtrl/HexEditorCtrl.h"
+ #include "HexEditorCtrl/wxHexCtrl/wxHexCtrl.h"
+-#include "../udis86/udis86.h"
++#include <udis86.h>
+
+ #ifdef WX_GCH
+ #include <wx_pch.h>
diff --git a/app-editors/wxhexeditor/wxhexeditor-0.23.ebuild b/app-editors/wxhexeditor/wxhexeditor-0.23.ebuild
new file mode 100644
index 000000000000..a108387185aa
--- /dev/null
+++ b/app-editors/wxhexeditor/wxhexeditor-0.23.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PLOCALES="ar cs de es fr hu_HU it ja_JP nl_NL pl pt_BR ro ru tr zh_CN"
+
+inherit eutils l10n toolchain-funcs wxwidgets
+
+MY_PN="wxHexEditor"
+
+DESCRIPTION="A cross-platform hex editor designed specially for large files"
+HOMEPAGE="http://wxhexeditor.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-v${PV}-src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ app-crypt/mhash
+ dev-libs/udis86
+ x11-libs/wxGTK:3.0[X]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}"
+
+pkg_pretend() {
+ tc-has-openmp \
+ || die "${PN} uses OpenMP libraries. Please use an OpenMP-capable compiler."
+}
+
+src_prepare() {
+ WX_GTK_VER="3.0" need-wxwidgets unicode
+ epatch "${FILESDIR}"/${P}-syslibs.patch
+
+ do_kill_locale() {
+ rm -r "${S}"/locale/${1}
+ }
+
+ rm "${S}"/locale/wxHexEditor.pot
+ l10n_find_plocales_changes "${S}"/locale '' ''
+ l10n_for_each_disabled_locale_do do_kill_locale
+}