summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-01-29 20:30:41 +0100
committerUlrich Müller <ulm@gentoo.org>2018-01-29 22:18:52 +0100
commitbddc7c2d2c803f9e621eee1a7bfa5916fbadd204 (patch)
tree4f2639b3cd8a5ecd396c885f1bf877f35cce4fe7 /app-editors/zile/zile-2.4.14.ebuild
parentapp-editors/zile: Add slot operator dependency for boehm-gc. (diff)
downloadgentoo-bddc7c2d2c803f9e621eee1a7bfa5916fbadd204.tar.gz
gentoo-bddc7c2d2c803f9e621eee1a7bfa5916fbadd204.tar.bz2
gentoo-bddc7c2d2c803f9e621eee1a7bfa5916fbadd204.zip
app-editors/zile: Version bump.
Package-Manager: Portage-2.3.20, Repoman-2.3.6
Diffstat (limited to 'app-editors/zile/zile-2.4.14.ebuild')
-rw-r--r--app-editors/zile/zile-2.4.14.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-editors/zile/zile-2.4.14.ebuild b/app-editors/zile/zile-2.4.14.ebuild
new file mode 100644
index 000000000000..74d312cf2c51
--- /dev/null
+++ b/app-editors/zile/zile-2.4.14.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Zile is a small Emacs clone"
+HOMEPAGE="https://www.gnu.org/software/zile/"
+SRC_URI="mirror://gnu/zile/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="acl test"
+
+RDEPEND=">=dev-libs/boehm-gc-7.2:=
+ sys-libs/ncurses:0
+ acl? ( virtual/acl )"
+
+DEPEND="${RDEPEND}
+ test? ( dev-lang/perl )"
+
+QA_AM_MAINTAINER_MODE=".*help2man.*" #450278
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ $(use_enable acl)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # AUTHORS, FAQ, and NEWS are installed by the build system
+ dodoc README THANKS
+
+ # Zile should never install charset.alias (even on non-glibc arches)
+ rm -f "${ED}"/usr/lib/charset.alias
+}